Always same error installation

I downloaded the Yunohost version 2h ago, 64bits for RPi3b. I created a .nohost domain
I tried to install
-Peertube
-Funkwhale
-Invidious

2022-11-22 21:02:20,003: ERROR - No se pudo instalar peertube: Ha ocurrido un error en el guión de instalación de la aplicación

Always same error…

Only runs SearX```

Hello
please share the full log

I reported on Indivious-ynh repository…
This is… https://paste.yunohost.org/raw/beloqaluci

so you get the same error for any app youre trying to install?
No se pudo instalar invidious: Ha ocurrido un error en el guión de instalación de la aplicación
Could not install invidious: An error has occurred in the application installation script

according to your log there are a lot of dependency issues
try to fix the dependencies by these commands:
sudo apt-get update --fix-missing
sudo apt-get install -f
sudo apt-get update
sudo apt-get clean
sudo apt-get autoremove
sudo apt --fix-broken install
sudo dpkg --configure -a

if it doesnt help only aleks suggest something

Hello
I have followed your instructions and it has not solved anything.
but I ran the command
sudo apt upgrade
It has checked for and installed updates.
It threw an error on a package and offered me to launch
sudo apt install --fix-broken
The result is:

root@caraculo:~# sudo apt install --fix-broken
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Correcting dependencies… Done
The following additional packages will be installed:
libc-dev-bin libc6 libc6-dev
Suggested packages:
glibc-doc
Recommended packages:
libnss-nis libnss-nisplus
The following packages will be upgraded:
libc-dev-bin libc6 libc6-dev
3 upgraded, 0 newly installed, 0 to remove and 110 not upgraded.
1 not fully installed or removed.
Need to get 0 B/4,760 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs… Done
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database … 50481 files and directories currently installed.)
Preparing to unpack …/libc6_2.31-13+rpt2+rpi1+deb11u5_arm64.deb …
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another p
rocess: Resource temporarily unavailable
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another p
rocess: Resource temporarily unavailable
dpkg: error processing archive /var/cache/apt/archives/libc6_2.31-13+rpt2+rpi1+d
eb11u5_arm64.deb (–unpack):
new libc6:arm64 package pre-installation script subprocess returned error exit
status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.31-13+rpt2+rpi1+deb11u5_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@caraculo:~#

The command dpkg --configure -a launch error too

thanks for you patience anda excuse my “google” english

Hi
sorry for the late response
i didn’t got any notifications from this post for whatever reason,

according to your log its look like there an issue with locked cache

please try the next commands:

Edit by @Aleks : honestly this sounds way too brutal … There’s no reason to force-remove libc6, that’s going to destroy the entire system …

Show/hide

sudo su
cd /
cd /var/cache/debconf/
delete any file you see there, they should be .dat files
for example:
rm config.dat-old
rm config.dat

after that run:
sudo apt-get clean
sudo apt-get autoremove
sudo dpkg --configure -a
sudo apt-get update

===========================================

if it doesn’t work delete the defected packages

try: sudo apt-get purge libc6
then check if files are still exists if they are delete them:
cd /
cd /var/lib/dpkg/info
rm libc6:amd64.conffiles
rm libc6:amd64.list
rm libc6:amd64.md5sums
rm libc6:amd64.postinst
rm libc6:amd64.postrm
rm libc6:amd64.preinst
rm libc6:amd64.shlibs
rm libc6:amd64.symbols
rm libc6:amd64.templates
rm libc6:amd64.triggers
rm libc6-dev:amd64.list
rm libc6-dev:amd64.md5sums

sudo apt-get clean
sudo apt-get autoremove
sudo dpkg --configure -a
sudo apt-get update

if all goes right and you are able to update your system
set back and install libc6
by the command:
sudo apt-get install libc6

@Aleks
no issue just trying to help,
i do manage my server in many cases when things like this happened i did fixed them by myself instead to post on the forum, but that’s just because i am experienced so in most cases i don’t see any problem,
you are right when it comes to other people who especially have limited knowledge in IT we need to be very careful,

in this particular case i didn’t told as i mentioned he can install libc6 afterwards,
but no doubt you are much much way professional than me in linux,
but as always if you have a better suggestion it will be probably more acceptable than mine,

It looks like something is blocking the lock on debconf, I’m thinking this is probably yet another case of : RPi images are partially broken because service 'userconfig-service' hangs on dpkg forever · Issue #2079 · YunoHost/issues · GitHub

We can check this with:

ps -ef --forest | grep -C3 userconf
ps -ef --forest | grep -C3 debconf

indeed
after launching his commands, including deleting the libc6 file, the system threw me an error in dpkg
My experience is very limited and I don’t like to ask for help constantly.
I decided to delete Yunohost and try Docker. I will go back to Yunohost. I want to keep learning.

I am very grateful for your time and help.