Ajuster automatiquement la date et l'heure

Mon serveur YunoHost

Matériel: Raspberry Pi 3
Version de YunoHost: 4.3.6.3 (stable)
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : oui
Si oui, expliquer: Le Raspberry Pi a été éteint pendant 2 mois. Je viens de le rebrancher aujourd’hui.

Description du problème

La date et l’heure ne se mettent pas à jour automatiquement au redémarrage.

J’avais installé Yunohost il y a environ 2 mois, configuré Bibliogram et 2 serveurs statics. Puis j’ai laissé le Raspberry éteint pendant 2 mois. Aujourd’hui je l’ai rallumé. Au début, les mises à jours du système ne fonctionnaient pas, ni par l’interface web ni par apt. Par le forum, j’ai trouvé que c’était parce que la date était incorrecte (c’était genre le 2 juin). J’ai manuellement changé la date, fait les mises à jour système et d’applications. Maintenant mon serveur est accessible et fonctionne bien… sauf que la date et l’heure ne sont pas mis à jour automatiquement aux redémarrages. Je viens de redémarrer 2-3 fois sans succès. Pourtant, le Raspberry a accès à internet et tout.

Alors, une idée pour réactiver l’ajustement automatique de la date et heure?

Pour info, j’ai utilisé date en CLI pour changer la date. J’ai fait exprès de la mettre 5 minutes en retard pour pouvoir voir si elle va se faire mettre à jour automatiquement.

Logs:
https://paste.yunohost.org/raw/garabofesi

Bonjour,

Afin de voir si la synchronisation automatique NTP est active, peux-tu faire un :

timedatectl status

Si ça n’était pas le cas tu peux faire :

sudo timedatectl set-ntp true

Par ailleurs, si tu souhaites avoir la date et l’heure de Paris, tu peux faire :

sudo timedatectl set-timezone Europe/Paris

Ou bien passer par la commande "raspi-config’, dans le menu ‘localisation’ puis ‘timezone’.

ppr

Sources :

C’est bizarre. J’ai mis la valeur à True comme tu as suggéré, et après avoir rebooté, mon raspberry pi a correctement mis à jour la date et l’heure.

Sauf que ça me dit encore que c’est inactif???

$ timedatectl status 
               Local time: Sun 2022-07-31 21:37:26 EDT
           Universal time: Mon 2022-08-01 01:37:26 UTC
                 RTC time: n/a
                Time zone: America/Montreal (EDT, -0400)
System clock synchronized: no
              NTP service: inactive
          RTC in local TZ: no

C’est normal??

J’ai vérifié sur un autre raspberry pi que j’ai et lui me dit que le service NTP est actif comme je m’attendrais:

$ timedatectl 
               Local time: Sun 2022-07-31 21:40:52 EDT
           Universal time: Mon 2022-08-01 01:40:52 UTC
                 RTC time: n/a
                Time zone: America/Toronto (EDT, -0400)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

Une idée?

Bonjour,

Je ne suis pas un spécialiste mais après avoir entré une nouvelle fois cette commande :

sudo timedatectl set-ntp true

que donne le résultat de celle-ci :

sudo service systemd-timesyncd status

Edit : avais-tu fait un redémarrage après sudo timedatectl set-ntp true ?

ppr

sudo service systemd-timesyncd status m’avait initialement donné:

Warning: The unit file, source configuration file or drop-ins of systemd-timesyncd.service changed on disk. Run 'systemctl daemon-reload' to reload 
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
  Drop-In: /usr/lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: active (running) since Sun 2022-07-31 21:42:38 EDT; 4 days ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 269 (systemd-timesyn)
   Status: "Synchronized to time server for the first time 129.250.35.251:123 (2.debian.pool.ntp.org)."
    Tasks: 2 (limit: 2059)
   CGroup: /system.slice/systemd-timesyncd.service
           └─269 /lib/systemd/systemd-timesyncd

Jul 31 21:42:37 pi2 systemd[1]: Starting Network Time Synchronization...
Jul 31 21:42:38 pi2 systemd[1]: Started Network Time Synchronization.
Jul 31 21:43:21 pi2 systemd-timesyncd[269]: Synchronized to time server for the first time 129.70.132.34:123 (2.debian.pool.ntp.org).
Aug 04 00:16:37 pi2 systemd-timesyncd[269]: Timed out waiting for reply from 129.70.132.34:123 (2.debian.pool.ntp.org).
Aug 04 00:16:48 pi2 systemd-timesyncd[269]: Timed out waiting for reply from 131.188.3.223:123 (2.debian.pool.ntp.org).
Aug 04 00:16:48 pi2 systemd-timesyncd[269]: Synchronized to time server for the first time 129.250.35.251:123 (2.debian.pool.ntp.org).

(note l’avertissement au début)

Donc j’ai fait systemctl daemon-reload comme suggéré par l’avertissement. Maintenant j’ai:

sudo service systemd-timesyncd status
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
  Drop-In: /usr/lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: active (running) since Sun 2022-07-31 21:42:38 EDT; 4 days ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 269 (systemd-timesyn)
   Status: "Synchronized to time server for the first time 129.250.35.251:123 (2.debian.pool.ntp.org)."
    Tasks: 2 (limit: 2059)
   CGroup: /system.slice/systemd-timesyncd.service
           └─269 /lib/systemd/systemd-timesyncd

Jul 31 21:42:37 pi2 systemd[1]: Starting Network Time Synchronization...
Jul 31 21:42:38 pi2 systemd[1]: Started Network Time Synchronization.
Jul 31 21:43:21 pi2 systemd-timesyncd[269]: Synchronized to time server for the first time 129.70.132.34:123 (2.debian.pool.ntp.org).
Aug 04 00:16:37 pi2 systemd-timesyncd[269]: Timed out waiting for reply from 129.70.132.34:123 (2.debian.pool.ntp.org).
Aug 04 00:16:48 pi2 systemd-timesyncd[269]: Timed out waiting for reply from 131.188.3.223:123 (2.debian.pool.ntp.org).
Aug 04 00:16:48 pi2 systemd-timesyncd[269]: Synchronized to time server for the first time 129.250.35.251:123 (2.debian.pool.ntp.org).

et

$ timedatectl 
               Local time: Fri 2022-08-05 09:21:44 EDT
           Universal time: Fri 2022-08-05 13:21:44 UTC
                 RTC time: n/a
                Time zone: America/Toronto (EDT, -0400)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

Donc je pense que ça va?
(et oui, j’ai rebooté plusieurs fois)

Bonjour,

D’après le résultat de la dernière commande timedatectl, ça devrait normalement fonctionner à nouveau car, au-delà du service NTP, le System clock synchronized est maintenant positionné à yes.

ppr