After updates, I can't access user login nor apps on YunoHost any more

My YunoHost server

Hardware: Raspberry Pi 4 with 8GB
YunoHost version: (just updated - may be part of the problem?)
I have access to my server : Both through the webadmin page and through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello all,

as of today I cannot access the user login and the installed apps any more. Till yesterday this had worked fine. Then I ran new system updates to v11.0.9.12 and the newest Nextcloud v24 update. I believe that these updates must have messed up something.

I do have access via webadmin and ssh login. Webadmin > Diagnosis shows these errors:

DNS records

Strange how some values are set to which is obviously wrong. I don’t know what caused this mess-up

Ports exposure

Two ports are not available (this all worked fine till yesterday)


I tried running
$ sudo yunohost dyndns update --force
but it resulted in an error with the following log:

I tried to set up individual port forwarding in my router, but that didn’t make the ports available again.

I’m a beginner with YunoHost and don’t know what these errors mean or how to fix them.

I’d appreciate your help – Thanks!

The errors displayed in the diagnosis don’t seem to be related

Can you elaborate why you “cannot” ? What happens when you try …


right now, I can access the webadmin page in a browser, and I can SSH into the Yunohost.

If I direct a browser to “https://yunohost.local/yunohost/sso/” for the user interface, I see the login prompts, but there is a big red box saying “Redirection error: Invalid URL”. But I can log in, and I see the tiles of installed apps.

If I click on a tile,

  • for some apps (Nextcloud or Jellyfin) I land on the webadmin page,
  • and for some others (Photoview) I get a “Server not found” error

The webadmin > Diagnosis still shows the same errors I posted above for DNS records and Ports Exposure (see above screenshots).

Thanks for your help!


@aleks, here is an update: I managed to fix most port exposure errors by redoing the port forwarding in my router.

Forwarding for ports 1900 and 7359 somehow doesn’t work, don’t know why. But even without those two, I can now access Nextcloud and Jellyfin from the browser.

The only remaining problem in the Diagnosis is the DNS record error:

I ran sudo yunohost dyndns update --force on the Yunohost and it terminated with “Success! Updated your IP on DynDNS”, but the error still persists.

Some of those settings clearly don’t make any sense, like “”. But since my server seems to work, should I just ignore this error? Are these weird settings maybe related to the Yunohost DynDNS administration on your side?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.