After Mastodon upgrade to 4.0.2, tootctl isn't working anymore

:uk:/:us: Message template (english)

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.1.15 (stable).
I have access to my server : Through SSH | through the webadmin |

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Mastodon 4.0.2~ynh2

Description of my issue

Hi guys,
So I upgraded Mastodon to 4.0.2 a while ago and everything works finde except for tootctl.

How to reproduce the error:
Login via SSH

sudo -i
cd /var/www/mastodon/live/
RAILS_ENV=production bundle exec bin/tootctl media usage

Now this has always worked but now I get the following error message:

rbenv: version `3.0.4' is not installed (set by /var/www/mastodon/live/.ruby-version)

So I tried:

rbenv install 3.0.4

But then trying to start tootctl I get another error: (at 870a34e@870a34e) is not yet checked out. Run `bundle install` first.

Any idea how to get tootctl working again?

Kind regards

I figured out this does the job:

sudo -u mastodon RAILS_ENV=production PATH=/opt/rbenv/versions/mastodon/bin bin/tootctl

But I would still try to understand the difference, maybe someone can answer this as I’n not familiar with ruby/rbenv.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.