Adresse en .noho.st non résolue / .noho.st address unresolved

fr
en

#1

Hi all,

Version française plus bas.

My YunoHost configuration

Hardware: old computer
Internet access: ethernet at home
YunoHost version:
yunohost: 3.3.3
yunohost-admin: 3.3.1
moulinette: 3.3.1
ssowat: 3.3.2
Have you personalized your yunohost with some specifics configurations or do you use only the yunohost cli/webadmin tool ? basic

Description of my problem

My instance cannot be reached anymore using its .noho.st address, neither through https nor ssh.

dnschecker.org shows that the address is not resolved.

I tried:

sudo rm /etc/yunohost/dyndns/old_ip
sudo yunohost dyndns update

and waited a few tens of minutes, but that was unsuccessful.

(Could it be related to the expiration of ip.yunohost.org certificates, reported in this recent post ?)

Thanks, and happy new year!


Salut et meilleurs vœux à tout le monde,

Configuration de mon YunoHost

Matériel: vieille tour
Accès Internet: ethernet à la maison
YunoHost version:
yunohost: 3.3.3
yunohost-admin: 3.3.1
moulinette: 3.3.1
ssowat: 3.3.2
As tu modifié ton yunohost avec des configurations spécifiques ou bien utilise tu uniquement la web administration et/ou la ligne de commande yunohost ? basique

Description de mon problème

Depuis ce matin, mon instance (qui pourtant ronronne doucement et ne montre aucun symptome particulier en console physique) n’est plus accessible par son adresse en .noho.st.

Un petit tour sur dnschecker.org confirme que l’adresse n’est plus résolue.

J’ai essayé les deux lignes de commandes citées dans la version anglaise ci-dessus, mais sans succès.

(Pourrait-ce être lié à l’expiration des certificats d’ip.yunohost.org, signalée ici?)

Merci!


Yunohost Innaccesible
#2

Same here, my host is unavailable today (nohost.me)


#3

Bonjour,

J’a également le même problème avec les noms de domaines en .ynh.fr.
Les membres de l’infra doivent être sur le coup.

Hi,

I’ve the same problem with the .ynh.fr domain name too.
I think infra’s members are on.

ppr


#4

I have the same problem with my nohost.me. domain.


#5

Pareil pour moi en .ynh.fr

[Errno 22] No DNS ‘A’ record found for abordes.ynh.fr. You need to make your domain name point to your machine to be able to install a Let’s Encrypt certificate! (If you know what you are doing, use --no-checks to disable those checks.)


#6

@sytnfh your diagnosis about ip.yunohost.org was right, there was an issue with certificate renewal.

It’s fixed ( see Certificate for ip.yunohost.org has expired! )


#7

Merci!


#8

Bonjour, je ne sais pas s’il faut que j’ouvre un autre fil, mais il me semble avoir le même souci: yunohost est d’un seul coup inaccessible par l’adresse extérieure, sans avoir rien modifié. Par l’adresse IP locale je n’ai accès qu’à l’interface d’administration. Je n’ai pas non plus de réponse avec dnschecker.org. Quand j’essaye de renouveler le certificat (qui est encore valable 58 jours) par l’interface graphique, j’ai cette réponse:

[Errno 22] Aucun enregistrement DNS « A » n’a été trouvé pour monadresse.nohost.me. De devez faire pointer votre nom de domaine vers votre machine pour être capable d’installer un certificat Let’s Encrypt ! (Si vous savez ce que vous faites, utilisez --no-checks pour désactiver ces contrôles)
Traceback (most recent call last): File “/usr/lib/moulinette/yunohost/certificate.py”, line 379, in certificate_renew _check_domain_is_ready_for_ACME(domain) File “/usr/lib/moulinette/yunohost/certificate.py”, line 819, in _check_domain_is_ready_for_ACME if not _dns_ip_match_public_ip(public_ip, domain): File “/usr/lib/moulinette/yunohost/certificate.py”, line 842, in _dns_ip_match_public_ip return _get_dns_ip(domain) == public_ip File “/usr/lib/moulinette/yunohost/certificate.py”, line 836, in _get_dns_ip ‘certmanager_error_no_A_record’, domain=domain)) MoulinetteError: [Errno 22] Aucun enregistrement DNS « A » n’a été trouvé pour monadressse.nohost.me. De devez faire pointer votre nom de domaine vers votre machine pour être capable d’installer un certificat Let’s Encrypt ! (Si vous savez ce que vous faites, utilisez --no-checks pour désactiver ces contrôles)
Certificate renewing for monadresse.nohost.me failed !


#9

Having the same issue as goalgauth, the DNS is not resolving for my nohost.me subdomain and the certificate says still valid for 42 days. Same error if I try to renew it… I didn’t change anything. Any solution?


#10

Same here, for ynh.fr . My yunohost can’t be accessed from outside.


#11

What happens if you try to yunohost dyndns update from SSH ?


#12

Nothing at all, but it doesn’t works…


#13

For me it says “Info: no update needed”.
EDIT: I tried the “rm” command part and then updating, and now it seems to be working again!

sudo rm /etc/yunohost/dyndns/old_ip
sudo yunohost dyndns update

#14

So much thanks tommyms !! I had same issue, didn’t know what to do for days :stuck_out_tongue:


#15

Just to confirm, are you and @tommyms running Yunohost 3.3.x ?


#16

@Aleks, no, v.3.1.0, I’ve downloaded the RaspberryPi image.


#17

Uh well that issue should be fixed in Yunohost >= 3.3.x then … consider upgrading (e.g. running apt update && apt dist-upgrade)


#18

Ok thanks, didn’t notice it was not the last version, I will update :slight_smile:
Just for information, you know why my actual ip was in this /etc/yunohost/old_ip file ?


#19

My understanding is that sometimes, a dyndns update was performed and thought to have work, but was in fact not properly applied “for real” for some reason … and therefore the current ip ended up being in /etc/yunohost/dyndns/old_ip as if the update worked when in fact it didn’t … but as said, that’s fixed in newer versions


#20

May I now tag the issue as solved (by last @ljf’s post and @Aleks’s one about yunohost version)?

Thanks!