Admin Panel works, the rest doesn't (anymore) and I am confused


Hello Yunohost people,

so I am happily running Yunohost for some months now, which was mostly used for the nextcloud and it worked really well.But since a couple of days, I cannot access the yunohost/sso anymore and I don’t know why, so I would be happy if you have any advice.

DNS Setup with DS-Lite was working

I have a DS-Lite connection and therefore no direct IPv4, but an IPv6 address. I routed the IPv4 to an external server, which forwards the request to to my home server via the domain name and IPv6 (using 6tunnel). For IPv6 a have a dynDNS set up.
This setup causes the yunohost diagnostics to throw some errors, but it worked fine for some months.

Problem: Server not found from outside local network

I suddenly cannot access yunohost/sso anymore, the browser just states “server not found”.
I have still access to the admin panel from my network and the diagnostics seem to suggest that everything is fine. Naturally, I thought something is wrong with the dns, but the settings seem to be fine and I also can’t access the website from the ouside using my ip directly.

Yunohost reinstall didn’t fix the issue

After updating the server and restoring old backups didn’t work, I decided to reinstall yunohost. But the problem remains, even for a brand new yunohost install.

Is there a way to access the user interface (yunohost/sso) from the local network?

Locally, I always end up in the admin panel and when I try to switch to yunohost/sso the browser states “server not found” and in the address bar, the ip adress switched to the domain name so I guess it tries to connect via internet. With local access to the sso, I could at least confirm that the website itself works.

I would appreciate any comments or ideas, because I don’t know what to do anymore.

My YunoHost server

Hardware: old PC
YunoHost version:
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
Yunohost diagnostics log:

It sounds like the issue is the incorrect DNS ‘A’ record as stated in the diagnosis

Hi Aleks!
thank you for the quick reply. I think the ‘A’ record is correct like this, because with my DS-Lite connection my home server cannot be reached via IPv4 directly. This is why the A record points to a different server which uses 6tunnel to forward the request to the IPv6 address of my home server. This has worked before, therefore my guess is that the issue is somewhere else.

Do you know how I can reach the yunohost userinterface (sso) locally?
Then I could confirm that the at least the yunohost server is working. So far I only managed to get to the admin panel

Add this line to the hosts file of your pc
Where the ip address is the local ip address of the server and the domain used.

1 Like

Thanks! So local access works, that means that something is wrong with the DNS or Port forwarding settings I guess…
Or do you have any other suggestions?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.