Admin Interface not accessible, Nextcloud not accessible, XMPP-server keeps working

Hi yunohost-community,

I greet you from Kiel, Europe. Thanks for your time to read my issue! :slight_smile:

This is my first request in the yunohost-community. I tried to read the guidance carefully, looked for similar issues and did my best to report everything that is necessary to solve the issue. If I nonetheless left important information out or could do better in future issue reportings, please let me know!

My YunoHost server

Hardware: Old computer (Zotac Mini PC, amd64)
YunoHost version: 4.2.4
I have access to my server : direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I have two problems:

  1. nextcloud does not work.
    After logging in to my yunohost-user and trying to open my nextcloud, I get this error message:
502 Bad Gateway (nginx)
  1. server admin interface does not work.
    When trying to log in to my yunohost server admin through the user interface, I get the error message:
Wrong password

What still works:

I can still use the XMPP-accounts that I created on my server and messages are delivered. I can open the server administrator interface. Also, I can login with my user account to my server and the installed applications are shown. I can only not open them without the error messages.

Some background and diagnosis for my server:

I am using the server for more than half a year now without major problems. The problems occurred suddenly - at least I am not aware of a particular thing that I did before the errors came up.

When typing in the command line “sudo yunohost diagnosis show” I get this log:

What I already tried:

a) I restarted my yunohost server.
b) I typed “sudo yunohost service restart php7.3-fpm” with the output “Success! Service ‘php7.3-fpm’ restarted”. The log output from “Success! Service ‘php7.3-fpm’ restarted” can be found here:

I am not sure whether I provided all necessary information. If anything is missing, please let me know - I will provide it. Thanks for any advice in advance!

Warm greetings,

That’s very much appreciated, thanks :+1:

From the logs you provided, it seems to be due to :

[06-Jun-2021 18:18:49] ERROR: [pool limesurvey] cannot get uid for user 'limesurvey'

Not sure exactly but something funky happened with limesurvey and its php conf …

This would require more info about the story behind limesurvey (is it still supposed to be working or is it an old app you remove at some point?)

A quick workaround can be to move that conf file elsewhere :

mv /etc/php/7.3/fpm/pool.d/limesurvey.conf /root/limesurvey.phpconf.bkp

The restart the service with yunohost service restart php7.3-fpm

If your password contains special chars, this may have been a ~small issue from the recent upgrade to 4.2. This should be fixed if you upgrade to the very latest version of Yunohost. Since you don’t have access to the webadmin, you can do so with the CLI with yunohost tools update system and yunohost tools upgrade system


Hey Aleks,

wow, you are my yunohost-god - both works again, my nextcloud and my admin-panel! I executed the four commands that you recommended. Thanks a lot for your advice and such a fast response. I would have been lost without you! :slight_smile:

I installed and used limesurvey some months ago but stopped using it 2 months ago. It nerver worked as I liked it to work and I am fine working with nextcloud-forms right now. So, after your quick fix worked, I would un-install it from the admin panel. Are there, from your perspective, any risks with that? Or should I first investigate what was the issue with it before I do so?

Thanks again a lot for your explanations and support - highly appreciated! :slight_smile:

Very happy greetings from Kiel,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.