Adguard as DNS serveur


I have installed Adguard via yunoshot on a VPS. I would like to use it as a DNS provider for my mobile phone. I configured the IP address of my VPS on “DNS Changer” and nothing happened :

I can not connect to for example
on the AdGuard IHM, I saw there is no DNS Query.

How can I find the problem ?

The address recommanded by AdGuard is x.y.z.t**:xx**.

The version of Yuno is
The version of Adguard is 0.107.43

Regards !

Hi titithebad,

Which flavour of mobile phone do you use?

What do you mean with that? And what is IHM?

is your port 53 opened on your router?

I do not use any router. AdGuard is installed on a VPS outside of my private network. I would like to use AdGuard Home when I do not use my Phone on my private Wifi.

The port 53 seems to be opened. I can I check that ?



I have an Android 12 mobile phone.

About DNS Changer : yes it is an application where you can specify only IP Address.

Update : port 54 is now opened (it is the port I have to open for AdGuard Home).

But still not working…

I think you have a similar bug as Question: How does this interfere with dnsmasq? · Issue #113 · YunoHost-Apps/adguardhome_ynh · GitHub

the normal port is the 53 and not 54, you can follow this comment to fix this manually

1 Like

I too am having this problem but specifically when trying to use the adguardhome dns in conjunction with yuno wireguard. I too am on a VPS and but my firewall says port 53 is blocked. This must be why adguard chose to use 54?

I don’t know
Have you tried to change the port to 53 using my link?

It is working now… The port is indeed 53 and not 54. I changed it with the tuto you gave me and it is OK…

Thank you very much !!!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.