Acces SSH - FTP impossible - VPS - OVH

, ,

Bonjour,

J’ai un VPS chez OVH comme le titre l’indique. Depuis quelques jours je n’arrive plus à me connecter à ce VPS en SSH et même via FTP.
J’ai suivi les consignes pour changer les mots de passe. Aucun effet. J’ai bien veillé à changer le mode de passe pour l’user et pas le root.
J’ai reinstallé également le VPS. Apr_s installation de Yunohost il devient impossible de se connecter.
Auriez-vous des pistes ?
merci

Normalement OVH fournit un accès de secours depuis ton interface client. Il faut redémarrer ton serveur en mode « rescue ». As-tu essayé de l’activer ?

Peut-être ai-je lu trop vite : as-tu accès à l’interface admin en ligne du serveur en question ? Si oui as-tu fait tourner le diagnostic ?

Merci pour tes réponses.

j’ai effectivement activé le mode rescue pour modifier le mot de passe.
J’ai réussi à connecté le ftp avec le mot de passe que je venais de définir (mode rescue toujours actif). Je redémarre le VPS. Acces denied en SSH et FTP.
Donc en mode admin impossible de me connecter au VPS une fois yunohost installé.
Quand j’ai réinstallé le VPS, j’ai pu me connecter en SSH, installer yunohost en ligne de commande, remettre ma sauvegarde. C’est à ce moment que l’accès devient impossible

c’est peut-être Fail2Ban qui bloque ?
J’ai lu cette page Sécurité | Yunohost Documentation mais n’étant pas super pro j’ai peur de faire des erreurs

Peux tu préciser avec quels utilisateurs tu essaies de te connecter en ssh (root, admin ou un autre user) ?

Tu devrais essayer avec l’utilisateur admin si ce n’est pas déjà fait. La piste fail2ban est une autre piste, notamment si tu as fait plus de 10 tentatives il faut attendre plusieurs minutes avant de pouvoir recommencer.

En utilisateur admin, ça ne fonctionne pas. (même après avoir tenté de changer le mot de passe)

Avec le mode rescue en root ça fonctionne.

J’avais demandé de l’aide du côté de OVH mais ce qu’il propose c’est soit de changer le mot de passe, soit de réinstaller le VPS…
Ce que j’ai fait mais ne résout pas le problème…

j’ai également
Le fichier de configuration /etc/nsswitch.conf semble avoir été modifié manuellement…

ce que je n’ai pas fait…

Hello !
J’ai encore du mal à comprendre ce qui ne fonctionne pas exactement. Parviens-tu à accéder à l’interface admin en ligne ?

oui, j’ai accès à l’espace admin.
C’est l’accès SSH en admin qui bloque.

Peux tu vérifier dans l’interface d’admin que les services nsswitch et nslcd sont bien actif ?
Tu ne nous a pas répondu concernant fail2ban, est-ce que c’est lui qui bloque ? (vu ta situation une désactivation très temporaire de fail2ban permetrait de valider ou non le problème).

Tout les services sont actifs.
J’ai essayé de me connecter après avoir désactivé fail2ban mais cela ne change rien.

Bonjour,

Ne sachant comment résoudre mon problème. J’ouvre et refais des diagnostics régulièrement.
J’ai un nouveau problème

Votre IP ou domaine xxxxxxxxxxxxxx est sur liste noire sur Spamhaus ZEN .
A device (computer, server, mobile phone, etc), or an app on a device that is using xxxxxxxxxxxxxx is infected, badly misconfigured, or compromised. It is making SMTP connections with multiple unrelated HELO values on port 25.

j’ai toujours

Le fichier de configuration /etc/nsswitch.conf semble avoir été modifié manuellement.

Il y a eu récemment un grand nombre d’échecs d’authentification. Assurez-vous que Fail2Ban est en cours d’exécution et est correctement configuré, ou utilisez un port personnalisé pour SSH comme expliqué dans Security | Yunohost Documentation.

La résolution DNS semble fonctionner, mais il semble que vous utilisez un /etc/resolv.conf personnalisé. (que je n’ai pas personnalisé - cette alerte je l’ai depuis longtemps)

est-ce que je peux faire quelque chose cleaner tout ça?

Pour le blacklistage spamhaus, il faut fair ela demande pour être déblacklisté

Pour nsswitch

yunohost tools regen-conf nsswitch --force

Pour la résolution DNS:

rm /etc/resolv.conf
ln -s /etc/resolvconf/run/resolv.conf /etc/resolv.conf

Non toi tu sembles avoir changé le mot de passe du rescue (pas de ton VPS). QUand tu es en rescue tu démarres sur un autre système et c’est à toi de monter le disque et de changer le mot de passe dans /mnt/hdd/etc/shadow (si le disque est monté sur /mnt/hdd

Est-ce que tu peux partager ce qui se passe quand tu essaies de te connecter en ssh. Là on a zero info, tu peux aussi utiliser l’option -v (ou -vvvv pour avoir beaucoup de détails) ?

Est-ce que par hazard tu n’aurais pas changer le port SSH (au lieu de 22 tu as mis un autre nombre)?

1 Like

JE vous remercie pour l’aide.
Je ne suis pas expert mais je ne compte pas les heures et les essais.

J’arrive à me connecter en SSH (putty) avec le mode rescue (root + mdp) de OVH :+1:
J’arrive à monter le disc (j’ai suivi cette page Changer le mot de passe root sur un VPS | Documentation OVH)
J’arrive j’arrive à changer le mdp.
Je redémarre le VPS. J’essaie de me connecter avec l’user “debian” réponse acces denied. (via filezilla ça me donne juste
Erreur : Échec de l’authentification.
Erreur : Erreur critique : Impossible d’établir une connexion au serveur)

Avant que j’ai ce problème (impossibilité de me connecter en SSH avec l’user “debian”) je n’ai pas essayé de changer son mot de passe. C’est suite à ce problème que j’essaie de changer le mdp.

J’ai vérifié la config SSH sur le bon disque. c’est bien le port 22

à quel moment dois-je utiliser l’option -vvvv ? en mode rescue?

De façon général, avec yunohost il faut te connecter avec le user admin (ou éventuellement root en cas d’auto-hébergement à la maison).
La configuration SSH par défaut de YunoHost interdit la connexion avec un autre utilisateur non autorisé.

Donc par défaut pour te connecter sur ton serveur depuis ton ordinateur , tu devrais faire:

ssh admin@domain.tld -vv

Maintenant, si ça ne marche pas mais que tu as accès à l’interface d’admin web, tu peux essayer plusieurs choses:

1. Autoriser un autre utilisateur en SSH

  • Aller sur la web admin
  • Se connecter
  • User > Manage groups and permissions
  • En bas, ajouter la permission ssh à un utilisateur yunohost spécifique préalablement créé (ex: toto)
  • Tenter de se connecter en ssh
ssh toto@domain.tld -vv

Si ça cça marche, tu peux ensuite essayer de te connecter en root

su

(il faudra taper le mot de passe root)

2. Changer le mot de passe root (via rescue) et autoriser root à se connecter

  • Dans la console du fournisseur de VPS, démarrer en mode rescue
  • Entrer en ssh dans le système rescue (avec les instructions du fournisseurs)
  • Monter le disque sur /mnt/hdd
  • Changer le mot de passe /mnt/hdd/etc/shadow (en générant)
  • Autoriser root à se connecter via ssh en passant PermitRootLogin yes dans le fichier /etc/ssh/sshd_config
  • Redémarrer le vps en mode normal
  • Tenter de se connecter en ssh
ssh root@domain.tld -vv
1 Like

Merci :smiling_face_with_three_hearts:
effectivement ça fonctionne en me connectant avec admin.
J’avais gardé en mémoire la connexion avec le user et mdp de OVH :sweat:

J’ai réussi à régler le problème “nsswitch”

Pour la résolution DNS, à priori aucun changement. (j’ai fait plusieurs tentatives, j’ai redémarré le serveur)

Pour le port 25, est-ce que je dois le désactiver ? est-ce qu’il y a une restriction à mettre?

Encore merci à tous !!