Accès impossible en local

Mon serveur YunoHost

Matériel: OLinuXino-LIME2 avec VPN
Version de YunoHost: 4.2.8.3 (stable)
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran | …
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Salut à toutes et tous,

Suite à la désinstallation d’une application que je n’utilisais pas (wifi hotspot), je rencontre un problème pour accéder à Yunohost depuis chez moi…
J’ai accès à mon serveur en SSH et j’ai accès au webadmin.
Par contre, impossible d’accéder à l’interface utilisateur en local. Les clients nextcloud sur les machines du réseau ne fonctionnent plus (“Aucune connexion au serveur Nextcloud”)

Par contre, depuis l’extérieur, j’ai bien accès à tout cela…

Auriez-vous une idée de ce que je pourrais tenter?

Un tout grand merci d’avance!

Quentin

Peux tu préciser ce que tu veux dire par là ? Que se passe t’il exactement ?

Salut,

Il m’est impossible d’accéder à “mondomaine.me” quand j’utilise la connexion internet sur laquelle se trouve mon serveur…
Firefox me répond que “Le délai d’attente est dépassé. Le serveur à l’adresse mondomaine.me met trop de temps à répondre.”

Depuis “l’extérieur” (une connexion 4G), j’ai accès à “mondomaine.me”…

C’est un miracle! :innocent:

Le problème a disparu comme par enchantement. J’ai de nouveau accès au portail Yunohost… Mystère…

Ça ressemble plutôt à un problème de hairpinning qui n’aurait rien à voir avec hotspot…

A moins bien sûr que tu utilisais systématiquement hotspot pour accéder à ton serveur avant de désinstaller hotspot?

https://yunohost.org/fr/administrate/troubleshooting/noaccess

Certaines box de FAI ne supportent pas le hairpinning et vous ne pouvez pas accéder à votre serveur depuis l’intérieur du réseau local (sauf à passer par l’IP locale). Pour contourner le problème, vous pouvez :

  • utiliser une connexion cellulaire (4/5G)
  • modifier le fichier /etc/hosts sur vos équipements
  • déclarer l’ip locale de yunohost comme resolveur DNS dans votre routeur (partie DHCP) et ouvrir le port 53 UDP sur votre yunohost en faisant attention de ne pas activer l’upnp sur le port 53. Surtout, n’ouvrez pas le port 53 de votre routeur.

Non non… je ne l’utilisais pas…

Si le problème réapparait, j’aurai des pistes en tout cas! Merci beaucoup!

Some routers, like AVM Fritzbox, disable it by default but can enable hairpinning by making entries for the domains that should resolve in the LAN; from their help page:

I think @Quent does not have this problem (or it would not disappear by magic), but maybe it helps the next reader of the thread.

Excuse me for breaking into the thread in English!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.