A successful backup of Misskey cannot be performed

Describe the bug

A successful backup of Misskey cannot be performed.


  • Hardware: Old computer
  • YunoHost version: 11.1.15
  • I have access to my server: Through SSH & through the webadmin
  • Are you in a special context or did you perform some particular tweaking on your YunoHost instance?: no
  • Using, or trying to install package version/branch: 12.119.2~ynh1

Steps to reproduce

I’m trying to perform a backup of Misskey. First, I tried to use the webadmin and it seems to have locked up the webadmin. Then, I went to the terminal and tried to back up Misskey using yunohost backup create --apps misskey. It tries to do the backup, but ultimately fails with this wording:
_Error: Could not add the files ‘/var/www/misskey’ (named in the archive ‘apps/misskey/backup/var/www/misskey’) to be backed up into the compressed archive ‘/home/yunohost.backup/archives/20230331-025254.tar’
Info: The operation ‘Create a backup archive’ could not be completed. Please share the full log of this operation using the command ‘yunohost log share 20230331-025254-backup_create’ to get help
Error: Could not create the backup archive


Expected behavior

I would expect a successful backup to be performed. I would then be able to access the backup from the webadmin and download the backup.

What actually happens, is there seems to be a backup file created if I use the terminal to view the folder at dir /home/yunohost.backup/archives, but there is no .json file. The webadmin then takes several hours to populate the backup section or sometimes times out with a 504 Timeout. I can successfully backup other apps.
I have tried to back up Misskey several times and I get the same result. There will be 20+gb .tar files created, but no .json file. There is over 100gb of storage left on my drive. I have deleted several of the failed attempts in order to create space for a successful backup.



Whether right or wrong, I don’t know. But as Misskey was trying to back up, it was looking for 2 different files. Since they didn’t exist, I created these files and left them blank. Misskey then would perform a backup. I even restored the backup on a test server, and it restored perfectly.
That is what I did to remedy this.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.