502 Bad Gateway with Nextcloud

My YunoHost server

Hardware: Lime 2
YunoHost version: 4.2.7
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I have installed several applications on Yunohost (Zerobin, Docuwiki, Fresh RSS and Nextcloud) and after installing some apps inside the Nextcloud (polls, calendar, contacts, notes, decks) I get the 502 Bad gateway error. After that Nextcloud and Docuwiki don’t work anymore (502). The other two work nice (I guess they don’t use nginx).
I’ve accessed the server via SSH and restarted the nginx and Docuwiki works. But if I try Nextoud I get 502 and after that error, Docuwki also gives me 502.

So it has to be something with Nextcloud…Is there a way to disable Nextcloud apps via SSH? Or is there some other trick about nginx and Nextcloud?


Mmh wouldn’t it rather be a problem with php-fpm ?
Can you check if all your services are running in the webadmin (or through ssh by something like sudo yunohost service status) ?

1 Like

I was in a hurry (never a good thing) and I uninstalled the Nextcloud and installed it again. Now it works. I checked service status and php7.3-fpm is running (for now).
I will repeat installation of the apps on Nextcloud and see what happens.

Everything went well. I have no idea what happened. You can close this thread and I can ask for reopening, if this happens again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.