400: Bad Request when accessing Home Assistant on local network through Redirect

My YunoHost server

Hardware: ODROID-HC4
YunoHost version: 11.2.14 (testing)
I have access to my server : Through SSH | Through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance? : No
If your request is related to an app, specify its name and version: Redirect 2.0~ynh3

Description of my issue

I’ve installed a Home Assistant instance on an RPi 4 on my local network, separate from my Yunohost server which is on a different ARM board. I want to be able to access HA from outside my local network by using the NGINX proxy on my Yunohost instance via the Redirect app, but I’m having some difficulty haha. I followed the instructions from this post by Xabi, but it still gives me the same error even when I tried doing it myself. I’m not entirely sure what I should do. What steps am I possibly missing? Anything I should do that isn’t listed in the instructions in that topic? Any help would be greatly appreciated. Thank you in advance!

Okay, my brain just did an oopsie haha. I forgot to restart Home Assistant after changing the configuration.yaml! Doing that made everything work great. Everything’s working now.