0021_migrate_to_bullseye : Failed to reinstall mariadb-common

Bonjour à tous,

J’espère que quelqu’un va pouvoir m’aider sur la migration vers Bullseye

Mon serveur YunoHost

Matériel: Raspberry Pi 4
Version de YunoHost:
yunohost:
repo: stable
version: 4.4.2.14
yunohost-admin:
repo: stable
version: 4.4.1
moulinette:
repo: stable
version: 4.4.1
ssowat:
repo: stable
version: 4.4.1

J’ai accès à mon serveur : En SSH & par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : je ne pense pas

Description du problème

J’ai tenté de faire la migration vers YunoHost 11.0 (Bullseye) mais je me suis retrouvé avec ce message d’erreur :

2022-09-12 14:53:11,622: INFO - + Reading package lists...
2022-09-12 14:53:12,193: INFO - + Building dependency tree...
2022-09-12 14:53:12,196: INFO - + Reading state information...
2022-09-12 14:53:12,300: INFO - + You might want to run 'apt --fix-broken install' to correct these.
2022-09-12 14:53:12,301: INFO - + The following packages have unmet dependencies:
2022-09-12 14:53:12,717: INFO - +  gcc : Depends: gcc-8 (>= 8.3.0-1~) but it is not going to be installed
2022-09-12 14:53:12,719: INFO - +  gfortran-8 : Depends: gcc-8 (= 8.3.0-6+rpi1) but it is not going to be installed
2022-09-12 14:53:12,721: INFO - +  libgfortran-8-dev : Depends: libgcc-8-dev (= 8.3.0-6+rpi1) but it is not going to be installed
2022-09-12 14:53:12,791: WARNING - E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
2022-09-12 14:53:13,793: ERROR - La migration 0021_migrate_to_bullseye a échoué avec l'exception Failed to reinstall mariadb-common ? : annulation

Lien vers le log complet

Hmoké, pas sur de capter pourquoi des trucs fortran seraient installés …

Creusons un peu avec :

LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none sudo apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes mariadb-common gfortran-8- libgfortran-8-dev- --reinstall -o Dpkg::Options::='--force-confmiss'

Merci Aleks pour ta réponse

Résultat de la commande :

LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none sudo apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes mariadb-common gfortran-8- libgfortran-8-dev- --reinstall -o Dpkg::Options::='--force-confmiss'
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gcc : Depends: gcc-8 (>= 8.3.0-1~) but it is not going to be installed
 gfortran : Depends: gfortran-8 (>= 8.3.0-1~) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


So eh let’s try to also uninstall gfortran é_è

LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none sudo apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes mariadb-common gfortran-8- libgfortran-8-dev- gfortran --reinstall -o Dpkg::Options::='--force-confmiss'

ça se présente un peu mal là non ? :grimacing:

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gcc : Depends: gcc-8 (>= 8.3.0-1~) but it is not going to be installed
 gfortran : Depends: cpp (= 4:10.2.1-1+rpi1) but 4:8.3.0-1+rpi2 is to be installed
            Depends: gcc (= 4:10.2.1-1+rpi1) but 4:8.3.0-1+rpi2 is to be installed
            Depends: gfortran-10 (>= 10.2.1-3~) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Ah my bad j’ai oublié le - après gfortran

LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none sudo apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes mariadb-common gfortran-8- libgfortran-8-dev- gfortran- --reinstall -o Dpkg::Options::='--force-confmiss'

Avec le -

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gcc : Depends: gcc-8 (>= 8.3.0-1~) but it is not going to be installed
 libcoarrays-dev : Depends: gfortran-10 but it is not going to be installed or
                            gfortran-mod-15
                   Depends: gfortran but it is not going to be installed or
                            fortran-compiler
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

zblerg bon sinon on peut s’y prendre autrement :

sudo apt install aptitude
sudo aptitude why gfortran

ça devrait nous expliquer pourquoi gfortran est installé

oupss… j’ai l’impression de ne plus pouvoir rien installer

sudo apt install aptitude
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 aptitude : Depends: aptitude-common (= 0.8.13-3) but it is not going to be inst                                                                                                                                                             alled
            Depends: libapt-pkg6.0 (>= 1.9.0) but it is not going to be installe                                                                                                                                                             d
            Depends: libboost-iostreams1.74.0 (>= 1.74.0) but it is not going to                                                                                                                                                              be installed
            Depends: libcwidget4 (>= 0.5.18-1) but it is not going to be install                                                                                                                                                             ed
            Depends: libsigc++-2.0-0v5 (>= 2.8.0) but it is not going to be inst                                                                                                                                                             alled
            Depends: libstdc++6 (>= 9) but 8.3.0-6+rpi1 is to be installed
            Depends: libxapian30 (>= 1.4.17~) but it is not going to be installe                                                                                                                                                             d
 gcc : Depends: gcc-8 (>= 8.3.0-1~) but it is not going to be installed
 gfortran-8 : Depends: gcc-8 (= 8.3.0-6+rpi1) but it is not going to be installe                                                                                                                                                             d
 libgfortran-8-dev : Depends: libgcc-8-dev (= 8.3.0-6+rpi1) but it is not going                                                                                                                                                              to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or speci                                                                                                                                                             fy a solution).

Mouarf beh dans ce cas on peut creuser à la main à coup de :

apt remove libcoarrays-dev --dry-run

et eventuellement continuer de apt remove --dry-run les paquets suivant jusqu’à comprendre l’origine …

Ça se complique si je peux plus remove non plus

sudo apt remove libcoarrays-dev --dry-run
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gcc : Depends: gcc-8 (>= 8.3.0-1~) but it is not going to be installed
 gfortran-8 : Depends: gcc-8 (= 8.3.0-6+rpi1) but it is not going to be installed
 libgfortran-8-dev : Depends: libgcc-8-dev (= 8.3.0-6+rpi1) but it is not going
to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Zgrmbl bon beh bourrinons un peu plus :

sudo apt remove libcoarrays-dev gcc gfortran-8 ibgfortran-8-dev libgcc-8-dev gcc-8 --dry-run
sudo apt remove libcoarrays-dev gcc gfortran-8 ibgfortran-8-dev libgcc-8-dev gcc-8 --dry-run
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ibgfortran-8-dev

My bad c’était "lib"fortran :confused:

sudo apt remove libcoarrays-dev gcc gfortran-8 libgfortran-8-dev libgcc-8-dev gcc-8 --dry-run

En vrai l’idéal ce serait qu’on en discute sur le chat …

@Aleks

J’ai un problème similaire:

https://paste.yunohost.org/raw/apoxaveliy

On an old laptop sitting in my living room.

EDIT: Apparently not related to fortran in my case, sorry for the noise, opening a new thread.

Salut,
Le résultat de la commande en attendant qu’on trouve un créneau pour discuter sur le chat

sudo apt remove libcoarrays-dev gcc gfortran-8 libgfortran-8-dev libgcc-8-dev gcc-8 --dry-run
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'gcc-8' is not installed, so not removed
Package 'libgcc-8-dev' is not installed, so not removed
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gfortran : Depends: gcc (= 4:8.3.0-1+rpi2) but it is not going to be installed
            Depends: gfortran-8 (>= 8.3.0-1~) but it is not going to be installed
 libtool : Depends: gcc but it is not going to be installed or
                    c-compiler
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Merci