Yunomdns service stopped!

My YunoHost server

Hardware: VPS bought online / Old laptop or computer / Raspberry Pi (specify version, 0 to 4) at home / Internet Cube with VPN / Other ARM board / …
YunoHost version: (testing)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

Hello everyone.

I have been running (testing) since it came out which must be four or five weeks ago. It has been working fine and continues to do so, however last week I started getting emails as follows:

 Services status check (services)
 [ERROR] Service yunomdns is failed :(
  - You can try to restart the service, and if it doesn't work, have a look at the service logs in the webadmin (from the command line, you can do this with 'yunohost service restart yunomdns' and 'yunohost service log yunomdns').

Indeed when I used the Web UI Tools/Services the yunomdns service had stopped and wouldn’t restart, even with a full reboot!

Here is the log:

I understand that yunomdns takes care of yunohost.local access.

I can contact my server using the IP address locally and remotely (using a VPN)

Should I be concerned? I do like to have a clean, all services working, setup so if anyone can help me out to get the service started I’d appreciate the help

Many thanks


there is a permission issue,

Dec 01 21:49:16 systemd[1]: Started YunoHost mDNS service.
Dec 01 21:49:16 yunomdns[343897]: Traceback (most recent call last):
Dec 01 21:49:16 yunomdns[343897]:   File "/usr/bin/yunomdns", line 191, in <module>
Dec 01 21:49:16 yunomdns[343897]:     sys.exit(0 if main() else 1)
Dec 01 21:49:16 yunomdns[343897]:   File "/usr/bin/yunomdns", line 68, in main
Dec 01 21:49:16 yunomdns[343897]:     with open("/etc/yunohost/mdns.yml", "r") as f:
Dec 01 21:49:16 yunomdns[343897]: PermissionError: [Errno 13] Permission denied: '/etc/yunohost/mdns.yml'

Can you share the output of getfacl /etc/yunohost/mdns.yml ?

There is indeed an issue with the yunohost regenconf hook setting the perm on mdns.yml as root instead of the value it should be: regenconf: fix yunohost hook incorectly tweaking mdns.yml ownership · YunoHost/yunohost@9bd9816 · GitHub

It’s fixed in 11.1

Nevertheless a quick workaround is to manually call yunohost tools regen-conf mdns followed by systemctl restart yunomdns for now

(Edit: service name typo)


with getfacl /etc/yunohost/mdns.yml

I get:

getfacl: Removing leading '/' from absolute path names
# file: etc/yunohost/mdns.yml
# owner: root
# group: root

Help or harm?

best wishes


@Aleks @tituspijean

Thank guys for the help…

I think I might wait until the 11.1 update to fix this. Ther server is working fine apart from this service.

Good idea?

Many thanks


… Dude you just need to run the two commands I wrote in my previous comment … It’s not like they are super risky or whatever …

@Aleks ok. I’m SSHing in now doing something else so… here goes…



systemctl restart mdns


Failed to restart mdns.service: Unit mdns.service not found




Yeah my bad it’s systemctl restart yunomdns

1 Like

@Aleks Scratch that… The error was retunred so I just went into the Admin GUI and did Tools/service and restarted the yunomdns service and its started ok… Great… All green ticks. I like that.

Thanks so much for the help


1 Like

Mine never stopped, but it also never worked…

That’s quite unhelpful here. Don’t hesitate to just revive your own thread.

If it never stopped, how do you know it has never worked? Confusing…



→ http(s)://yunohost.local

So does the service show that it is running, but you still get no access as .local?


That’s it.
I can access the server with the local IP (, with the, but access denied with yunohost.local.

Closing here, GoustiFruit already has a thread about their issue.