Yunohost System update is failing after fresh install (11.0.9, Bullseye)

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version: 11.0.9
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I followed the procedure described here : Installer YunoHost | Yunohost Documentation
Installation is working well and the procedure can be followed to the end. However trying to update the system fails after that, even with no application installed and no extra configuration performed.

From the web interface we have

Erreur: "500" Internal Server Error
Action: "PUT" /yunohost/api/upgrade/system
[…]
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/moulinette/interfaces/api.py”, line 460, in process
ret = self.actionsmap.process(arguments, timeout=30, route=_route)
File “/usr/lib/python3/dist-packages/moulinette/actionsmap.py”, line 586, in process
return func(**arguments)
File “/usr/lib/python3/dist-packages/yunohost/log.py”, line 419, in func_wrapper
result = func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/yunohost/tools.py”, line 513, in tools_upgrade
packages_list=", ".join(upgradables),
TypeError: sequence item 0: expected str instance, dict found

From the command line, apt-get update && apt-get upgrade asks to run ‘apt --fix-broken install’ which gives the following error :

debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database … 50071 files and directories currently installed.)
Preparing to unpack …/libc6_2.31-13+rpt2+rpi1+deb11u4_arm64.deb …
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing archive /var/cache/apt/archives/libc6_2.31-13+rpt2+rpi1+deb11u4_arm64.deb (–unpack):
new libc6:arm64 package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.31-13+rpt2+rpi1+deb11u4_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

This seems to be an issue but is there any workaround?

Hello there!
It seems some process is hanging stuck onto your apt. There’s a good chance it might be your yunohost upgrade that failed earlier.
You could probably solve this with a reboot of your server, but if you want to investigate some more try:

sudo ps -ax | grep apt

Or

sudo ps -ax | grep dpkg

Let us know what comes from this,
Happy hacking !

Thank you very much for your answer.

I also thought rebooting could fix it but it did not.

The commands results :

sudo ps -ax | grep apt
1943 pts/0 S+ 0:00 grep apt

sudo ps -ax | grep dpkg
679 tty8 S+ 0:00 /usr/bin/perl -w /usr/sbin/dpkg-reconfigure -p critical keyboard-configuration
685 ? S 0:00 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -7 /etc/dnsmasq.d,.dpkg-dist,.dpkg-old,.dpkg-new --local-service --trust-anchor=.,20326,8,2,e06d44b80b8f1d39a95c0b0d7c65d08458e880409bbc683457104237c7f8ec8d
911 tty8 S+ 0:00 /bin/sh /var/lib/dpkg/info/keyboard-configuration.config reconfigure 1.205
1940 pts/0 S+ 0:00 grep dpkg

I tried to kill the dpkg processes but I still have the same error.

A process was indeed locking some file but it was restarting so killing it wasn’t solving the problem, the following did:
mv /var/cache/debconf/*.dat /tmp

After that I could update the system.

I still think there might be a problem with the image (https://build.yunohost.org/yunohost-bullseye-11.0.9-rpi-stable.img.zip).

1 Like

Yes indeed, follow-up issue: RPi images are partially broken because service 'userconfig-service' hangs on dpkg forever · Issue #2079 · YunoHost/issues · GitHub

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.