Yunohost installation on DigitalOcean droplet

Hi! Very happy to know that Yunohost forum runs with Discourse software (i have a profile on Meta)

I’m trying to install Yunohost on a 512MB - Ram20GB SSD Disk - Debian 7.0 x64 Droplet but the system always shows me this error:

======== Installation failed ========
Rolling back have to be done manually !
Check your legacy configuration files => '/etc/yunohost/.legacy’
Check install logs => ‘/var/log/yunohost.log’ and ‘/var/log/yunohost.error’

I follow the steps on this guide:
I’ve tried to uninstall apache before the final step but nothing works :frowning:

Have you been able to install Yunohost on DigitalOcean?

Thanks for your beautiful work!

Hi David,

You should try to install YunoHost a second time with the script. It worked for me, I was able to install YunoHost on DigitalOcean.

Finally, I managed the installation succesfully! :smile:

Maybe it’s a coincidence, but i’ve done two changes from the bad installation to the successful one:

1. Before, i’ve run:

cd /tmp/install_script && sudo ./install_yunohostv2


cd /tmp/install_script
sudo ./install_yunohostv2

2. Before, I’ve introduced a ssh key to avoid password in order to manage the server, now I’ve done with password.

This is the log from in the bad try into var/log# yunohost.log (at the bottom):

Removing sudo …
You have asked that the sudo package be removed,
but no root password has been set.
Without sudo, you may not be able to gain administrative privileges.

If you would prefer to access the root account with su(1)
or by logging in directly,
you must set a root password with “sudo passwd”.

If you have arranged other means to access the root account,
and you are sure this is what you want,
you may bypass this check by setting an environment variable
(export SUDO_FORCE_REMOVE=yes).

Refusing to remove sudo.
dpkg: error processing sudo (–remove):
subprocess installed pre-removal script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks for your support!!

sudo is interfeering with sudo-ldap (which we use in YunoHost).

Just uninstall sudo via apt, then retry the installation :blush:

EDIT: Oh, didn’t see it worked out, congratz !

I had the same trouble;
i’d resolve it by define a password for root and add a user [yhn] into sudo group

# apt-get install sudo

# passwd root

# adduser yhn

# usermod -a -G sudo yhn

after that I’d reconnect as yhn then

Thanks @jodumont
This resolve my trouble

I have been using Cloudways platform for managing the digitalOcean hosting. But it seems like, the process is a lot easier with Yunohost as it is also providing the managed service. Is it the same as it looks like or it is just hype.