YunoHost-Apps/mastodon_ynh

Upgrade went fine from a v2.6.x instance.
Thanks for the awesome work!

2 Likes

Thanks for packaging this app!
I’m having trouble with the post-install. When trying to create a user/admin from the command line, it was failing with:

   /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- bundler/setup (LoadError)
	from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /var/www/mastodon/live/config/boot.rb:3:in `<top (required)>'
	from bin/tootctl:3:in `require_relative'
	from bin/tootctl:3:in `<main>'

After searching around, I installed bundler. But now I get:

\Your Ruby version is 2.3.3, but your Gemfile specified >= 2.4.0, < 2.7.0

In frustration, I edited the Gemfile, and now I get:

Your bundle is locked to rake (12.3.2), but that version could not be found in any of the sources listed in your Gemfile. If you haven’t changed sources, that means the author of rake (12.3.2) has removed it. You’ll need to update your bundle to a different version of rake (12.3.2) that hasn’t been removed in order to install.

I’m afraid to keep stabbing around in the dark here. What should I do?

You tried to create user/admin from the command line ? Can you provide the command you used
Or
The error is during the installation ? Can you then provide a link to the full logs

Yes, I followed this instruction here:

I am unable to create a user from the webpage, because it requires the server to send an email for confirmation, and I haven’t been able to properly configure my ynh mail server. That’s why I tried the alternate method above.

Have you checked on your YunoHost, the mail of first YunoHost user you created ?
You just have to install rainloop using yunohost app install rainloop, log in the YunoHost Web interface with the first user you created on YunoHost and go to rainloop.

1 Like

I think I tried installing rainloop, but had some problem installing it. Anyway, I can use k9mail client on my phone to log in to those email accounts, but have not been able to enable outgoing messages. I can receive a message there from say, gmail, but I cannot reply. It seems like it must be a port issue, but as far as I can tell, everything is setup right. My ynh server is at my house, but (because my ISP blocks some ports) I have it connect to a VPS via wireguard. I have wireguard rules to allow/forward all relevant ports, and also opened those ports on the VPS firewall. This has generally been working as expected (allows me to obtain LE certs, for example). I don’t know why email doesn’t work.

To create an admin account you have to do
( cd /var/www/mastodon/live && sudo -u mastodon env PATH=$PATH:/opt/rbenv/versions/2.6.1/bin/ RAILS_ENV=production bin/tootctl accounts create "papa" --email="papa@domain.tld" --confirmed --role=admin)

1 Like

During install, Mastodon send an email to the local root user, so the mail doesn’t sent out of your YunoHost server. The mail is directly stored locally.

1 Like

You are right on both counts, of course :smile: My mistake was not doing ‘-u mastodon’. I still need to figure out how to get emails to send from my server accounts, but that is a different issue. For now, I am able to use and administer my mastodon instance. Thank you again for maintaining this package, and your assistance with my problems.

Ok, I just attempted the new update, and it failed. Not only that, but mastodon is no longer available to me. The url redirects to my server sso page, where mastodon is not listed. It IS listed as an installed application in the admin interface, and also shows update available. However update keeps failing. Here is the log of my most recent attempt:

https://paste.yunohost.org/raw/nalokefimo

Why are you trying to upgrade your mastodon version, you already are at the last version …

and the upgrade fails because mastodon-web service wasn’t started

Maybe it will be better to remove mastodon and reinstall it from scratch

I only tried to upgrade, because ynh admin showed one available. Anyways, I uninstalled and have been trying to reinstall mastodon, but it keeps failing. Here is the latest log:

https://paste.yunohost.org/raw/guhabayivo

OK, the error come from there is already a mastodon_production database in your postgresl
You need to remove it.
A good way is to use pgadmin_ynh to remove the mastodon_production database

Before I saw your reply, I was attempting install again (from web admin this time). The server lost connection in the middle of install, so I just clicked install again. Somehow it worked this time :stuck_out_tongue:

I don’t understand how any of this works, but maybe it’s my machine? It’s pretty low-specced, 32bit processor. Thanks again for your help :slight_smile:

#Mastodon 2.9.3 for #YunoHost has been released.

#Mastodon is a free, open-source social network.

Lot of adds, changes and fixes : https://github.com/tootsuite/mastodon/releases/tag/v2.9.3

Upgrade using:

$ yunohost app upgrade mastodon -u https://github.com/YunoHost-Apps/mastodon_ynh

@yunohost@mastodon.social
@Mastodon@mastodon.social
#Mastodon for #YunoHost has been upgraded to 3.0.1.

#Mastodon is a free, open-source social network.

Lot of adds, changes and fixes : https://github.com/tootsuite/mastodon/releases/tag/v3.0.1

Upgrade using:

$ yunohost app upgrade mastodon -u https://github.com/YunoHost-Apps/mastodon_ynh

1 Like

je trouve bloqué pour la mise à jour un probléme espace disque sur le vps:
Now creating a backup archive from the files collected…
2019-10-13 17:27:18,642: DEBUG - 2980016 Creating the backup tar archive…
2019-10-13 17:27:18,644: DEBUG - 2980114 Not enough space at /home/yunohost.backup/archives (free: 27817291776 / needed: 61124306850)
2019-10-13 17:27:18,645: DEBUG - 2980706 action [6993.1] executed in 2977.812s
2019-10-13 17:27:18,849: WARNING - 2980810 Not enough free disk space on ‘/home/yunohost.backup/archives’
2019-10-13 17:27:32,446: DEBUG - + ‘[’ 1 -eq 0 ‘]’
2019-10-13 17:27:32,453: DEBUG - + ynh_die ‘–message=Backup failed, the upgrade process was aborted.’
2019-10-13 17:27:32,560: DEBUG - + local legacy_args=mc
2019-10-13 17:27:32,561: DEBUG - + args_array=([m]=message= [c]=ret_code=)
2019-10-13 17:27:32,562: DEBUG - + declare -Ar args_array
2019-10-13 17:27:32,571: DEBUG - + local message
2019-10-13 17:27:32,572: DEBUG - + local ret_code
2019-10-13 17:27:32,573: DEBUG - + ynh_handle_getopts_args ‘–message=Backup failed, the upgrade process was aborted.’
2019-10-13 17:27:32,751: DEBUG - + set +x
2019-10-13 17:27:32,852: DEBUG - + echo ‘Backup failed, the upgrade process was aborted.’
2019-10-13 17:27:32,853: WARNING - Backup failed, the upgrade process was aborted.
2019-10-13 17:27:32,854: DEBUG - + exit 1
2019-10-13 17:27:34,241: ERROR - Unable to upgrade mastodon
quelqu un aurait il une idée pour contourner ce problème?

Bonjour,
Enlever des archives plus anciennes ?
Ou sélectionner uniquement une partie de tes données à sauvegarder…
https://yunohost.org/#/backup_fr