Yunohost 11.1 spooky testing

I will try use a snapshot, because it is for someone who don’t care about testing…

Tell me if I can backup the mails, upload the mails’backup, restore a snapshot before this upgrade, restore the mails (do I need remove them before) and edit the sources to stay on stable branch… Is it possible ???
Or if I just stay on stable branch keeping these new changes, is it a bad idea ??

OK so… I am unwillingly testing v11.1 since my main VPS was left on testing (I thought it had reverted back to main after v11 migration :sweat_smile: )

  1. There was a kernel upgrade available which asked me to reboot the server
  2. Upon reboot
    • NGINX is dead
    • SSH is not responding to the port I had configured in global settings
    • I did receive the first diagnosis email of the day, as well as a Nextcloud one stating that I was added to the admins group
  3. SSH port has reverted back to 22, so I was able to log in back with SSH
    • Restarted NGINX with success
  4. Logged in the webadmin and SSH with my username :white_check_mark:
    • Reapplied the ssh setting from webadmin
  5. Be amazed by the webadmin dark mode :white_check_mark:
    • :warning: Indeed white-on-yellow text is hard to read. Maybe switch it to black or darken the yellow?
  6. Upgrade a bunch of apps :hourglass_flowing_sand:
  7. Domains view :heart:
    • List by level domain :white_check_mark:
    • Displaying installed apps in the domain? Oh gosh that’s great. One small issue though, with a top level domain that lists all apps.
    • Clicking away from the domain tooltip does not close it, one has to click the circled question mark again.
    • Registrar information and LE install button for .local domains should not be displayed, I guess?


Jusqu’à présent Pour l’instant, l’activation/désactivation des fonctionnalités de messagerie ou XMPP n’a d’impact que sur la configuration DNS recommandée et automatique, et non sur les configurations système !


:warning: Issue while installing Synapse:

Info: DEBUG - + yunohost user create synapse -f Synapse -l Application -d synapse.domain.tld -p **********
Info: WARNING - Not a tty, can't do interactive prompts

The command indeed tries to open an interactive prompt asking for the full name of the user.

Most likely a side effect of Merge firstname and lastname by alexAubin · Pull Request #1516 · YunoHost/yunohost · GitHub encoutering synapse_ynh/install at 2d04bb3fb9eb6ba2b1534c5bcb52645c0f343c34 · YunoHost-Apps/synapse_ynh · GitHub.

I guess it’s better to patch the app instead of the core, do you agree @Josue?

PR opened: Prep app for YunoHost 11.1 by tituspijean · Pull Request #348 · YunoHost-Apps/synapse_ynh · GitHub


@ericg : if you’re stuck outside of your ssh connection, you can install “Shell in a box” which give you access to command line via web, providing you have a user and a password (I got the same issue one week ago :slight_smile: )

1 Like

If you need someone to test your PR don’t hesitate as I’m stucked with the same issue (cf: Installation / Upgrade of synapse server )

1 Like

I just tried to remove the admin user and I had some problems, I think this is nothing, just hooks to apps to remove the admin user, where it was not created.
Here are the logs :

On another note, since the 11.1 upgrade, I just noticed today that I received many Undelivered Mail errors.

Here is for example the firsts line of one of these emails :

This is the mail system at host I’m sorry to have to inform you that your message could not be delivered to one or more recipients. It’s attached below. For further assistance, please send mail to postmaster. If you do so, please include this problem report. You can delete your own text from the attached returned message. The mail system (expanded from user unknown

Reporting-MTA: dns; X-Postfix-Queue-ID: 869425670DB X-Postfix-Sender: rfc822; Arrival-Date: Fri, 4 Nov 2022 08:49:08 +0100 (CET) Final-Recipient: rfc822; Original-Recipient: rfc822; Action: failed Status: 5.1.1 Diagnostic-Code: x-unix; user unknown

This email was sent to And the strange thing is that I received the mail in error, that was also addressed to

I just added aliases for everything in my user configuration, to see if it correct things…

Updated to 11.1 everything is really great.
One issue I have found, is in the domain section.
I can see and configure all the subdomains, but when I try to click on the main domain i get an error:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/moulinette/interfaces/", line 460, in process
    ret = self.actionsmap.process(arguments, timeout=30, route=_route)
  File "/usr/lib/python3/dist-packages/moulinette/", line 586, in process
    return func(**arguments)
  File "/usr/lib/python3/dist-packages/yunohost/", line 159, in domain_info
    {"name": app_info(app)["name"], "id": app, "path": settings["path"]}
KeyError: 'path'

So unable to configure dns and such

@Centralscrutinizer21 : yes that’s probably because you have a non-webapp installed on that domain. I just pushed a release that includes a fix for this a couple minutes ago :stuck_out_tongue_winking_eye:


I have synapse, and bludit on that domain…Amazingly fast response :zap:

Updated and working :+1:

Merci beaucoup! J’ai pu enfin indiquer à mon adresse que j’utilise un relai smtp.

I updated to 11.1, logged in the webadmin with my main user, deleted the old admin user.
I, then, tried to connect through SSH with my main user and got “Permission denied, please try again.”
Connection with Shell in a Box works like a charm… and other features are great!
Any suggestions?

So… I saw there were a few updates, applied them all, and only when I tried to sign back in did I find out it was the beta. This is the good server so I’m surprised I switched to the testing branch, I thought I was in stable :thinking:


  • the tree view for the domains is sexy but it’ll take me a while to get used to it.

  • thanks for the dark theme — my eyes are grateful. Maybe an option to follow system colour settings would be nice so that there is no need to do it manually, something like @media (prefers-color-scheme: dark, or is it included?).

  • upgraded Nexcloud (24.0.5 to 24.0.7). The process was successful but I see a caution triangle at the bottom of the screen. I doubt this is related to the new YunoHost version, but just in case:

sudo -u nextcloud php8.0 --define apc.enable_cli=1 occ --no-interaction --no-ansi maintenance:mode --off
WARNING - Nextcloud or one of the apps require upgrade - only a limited number of commands are available
WARNING - You may use your browser or the occ upgrade command to do the upgrade
  • I can SSH into the server with the first user. sudo su works, but su doesn’t — authentication failure. (I never changed the port so I haven’t had issues with that)

  • I have changed root password to the password that I was using for admin. The password is 40 characters long, but the placeholder dots seems to ignore this so I’m not sure the changes have been saved.

1 Like


I had an unexpected surprise that might be related to the previous post : I just installed a fresh Yunohost on a virtual machine, from the ISO provided on the website.
The installation went just fine, but I ended up with v (testing) (according to the portal).
With the CLI, yunohost --version answers this :

  repo: testing
  repo: testing
  repo: stable
  version: 11.0.9
  repo: stable
  version: 11.0.9

The APT sources are configured for stable :

## YunoHost repository
deb bullseye stable

And an APT search for yunohost gives this 4 results :

moulinette/stable,now 11.0.9 all  [installed, automatic]
  prototype interfaces with ease in Python

ssowat/stable,now 11.0.9 all  [installed, automatic]
  user portal with single sign-on designed for Yunohost

yunohost/stable,now all  [installed]
  manageable and configured self-hosting server

yunohost-admin/stable,now all  [installed]
  web administration interface for yunohost

I’m ok with the testing version but i thought it could be useful to report this.
Anyway, thanks for the amazing work :slight_smile:

1 Like

Hi there.

  repo: testing
  repo: testing
  repo: stable
  version: 11.0.9
  repo: stable
  version: 11.0.9

Updated yesterday, got issue when some bash script sends mail to root@mydomain.tld. Received this mail :

This is the mail system at host mydomain.tld.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<[admin@mydomain.tld](mailto:admin@mydomain.tld)> (expanded from <[root@mydomain.tld](mailto:root@mydomain.tld)>): user unknown

Reporting-MTA: dns; mydomain.tld
X-Postfix-Queue-ID: 942443862215
X-Postfix-Sender: rfc822; [root@mydomain.tld](mailto:root@mydomain.tld)
Arrival-Date: Fri, 4 Nov 2022 23:35:28 +0100 (CET)

Final-Recipient: rfc822; [admin@mydomain.tld](mailto:admin@mydomain.tld)
Original-Recipient: rfc822;[root@mydomain.tld](mailto:root@mydomain.tld)
Action: failed
Status: 5.1.1
Diagnostic-Code: x-unix; user unknown

[Original mail content]

Let’s check /var/log/mail.log :

Nov  5 00:08:35 mydomain postfix/pickup[2942463]: E9C8B386237F: uid=0 from=<root@mydomain.tld>
Nov  5 00:08:35 mydomain postsrsd[2961828]: srs_forward: <root@mydomain.tld> not rewritten: Domain excluded by policy
Nov  5 00:08:35 mydomain postfix/cleanup[2961824]: E9C8B386237F: message-id=<20221104230835.E9C8B386237F@mydomain.tld>
Nov  5 00:08:35 mydomain postfix/qmgr[2896068]: E9C8B386237F: from=<root@mydomain.tld>, size=529, nrcpt=3 (queue active)
Nov  5 00:08:36 mydomain postfix/pipe[2961830]: E9C8B386237F: to=<admin@mydomain.tld>, orig_to=<root@mydomain.tld>, relay=dovecot, delay=0.17, delays=0.12/0.01/0/0.04, dsn=5.1.1, status=bounced (user unknown)
Nov  5 00:08:36 mydomain dovecot: lda(someuserinadminsgroup@mydomain.tld)<2961835><fm7kAHSbZWOrMS0AUZszow>: sieve: msgid=<20221104230835.E9C8B386237F@mydomain.tld>: stored mail into mailbox 'INBOX'
Nov  5 00:08:36 mydomain postfix/pipe[2961833]: E9C8B386237F: to=<someuserinadminsgroup@mydomain.tld>, orig_to=<root@mydomain.tld>, relay=dovecot, delay=0.17, delays=0.12/0.02/0/0.03, dsn=2.0.0, status=sent (delivered via dovecot service)

Seems the system can’t find admin@mydomain.tld

Let’s have a look at the listed users :

root@mydomain:/home# yunohost user  list
    fullname: Admin
    mail: admin_legacy
    mailbox-quota: 0
    username: admin

    fullname: xxx yyy
    mail: someuserinadminsgroup@mydomain.tld
    mailbox-quota: 0
    username: someuserinadminsgroup
[some regular users]

Is it normal to get admin_legacy mail instead of admin@mydomain.tld like the other users ?

Nota bene : the user someuserinadminsgroup@mydomain.tld which is in the group admins receives the two mails : the original one and the error one.

Here are the users in the admin & admins groups :

root@mydomain:~# getent group admin && getent group admins

I got the update via admin web interface and I for sure didn’t switch to testing ever.

Hello, what’s the matter ?? I have a server for lot of users, I have verify before, the /etc/apt/sources.list.d/yunohost.list is edited with deb bullseye stable but this release has come and now I have this

# yunohost tools versions
  repo: testing
  repo: testing
  repo: stable
  version: 11.0.9
  repo: stable
  version: 11.0.9

why ??
Ok, it is a nice job the new webadmin. I had to edit again the aliases for the principal admin user (webmaster postmaster, admin, root, abuse).

I am affraid having a testing branch in this server which is dedicated for few users and offer services … And don’t understand why the apt have decided do this !!

For another server with similar problem last week, I have restore a snapshot (from OVH) to get back to a stable branch… But in this server, I have backups (each night with Borg), but it I am affraid restoring all…

How can I stay to stable branch, even keeping these changes ?

Is it possible keep this upgrade from testing but stay now the stable branch, and how be sure to stay on this stable branch ???

hi, me too I don’t understand why I got this release in this server which should be stable ???

1 Like

It was a mistake, see Passage en "Testing" suite migration - #9 by yalh76

1 Like