Ynh 2.4 kanboard admin

,

Hello,

i have many ynh instances, some newly installed in 2.4, some not
i’m using kanboard successfully so far, but with ynh 2.4 i can’t access to the kanboard admin settings :frowning:
ofcourse i am using the user i selected to be admin on installation, but my role is user only
i looked for differences between working install and not-working ones but couldn’t find any
am i the only one with this problem, is it really related to ynh 2.4
any feedback and help would appreciated here :wink:

Hi,
I am not sure I have ever managed to reach a setting or administration panel in Kanboard under YunoHost. I haven’t tried Kanboard outside from YunoHost, so I can’t really tell what admin panel I should be able to have access to, but it feels like I am not admin in Kanboard even though I am under YunoHost.
For instance, to install a plugin, I copy/paste folders manually since I have never found any way to do this from within the Kanboard user interface.

@jellium can you access to this url ? /kanboard/?controller=config&action=index
me neither, even with admin access i can’t install extensions from the web ui.

You are right: I can’t access to /kanboard/?controller=config&action=index either, it says forbidden access (“Accès interdit”) displayed by a red ribbon.
I think - yet I am not sure - that a corresponding issue has been opened on Kanboard’s Github repository.

@jellium well without these settings we are missing a lot of kanboard’s power :confused:
thanks for the link

I am looking for the LDIF data the developer is asking for on the issue thread, but I can’t seem to find anything. It would be nice if we could provide this piece of information.

i think we can get it with slapcat > ldif

there is an issue on the kanbaord_ynh repos https://github.com/YunoHost-Apps/kanboard_ynh/issues/29
official package of kanboard is not up to date
to get the admin panel working you have to remove the app (backup your contents before) and reinstall it from github
yunohost app remove kanboard yunohost app install https://github.com/YunoHost-Apps/kanboard_ynh

1 Like

OK, good point.
Just to make sure not to do anything stupid, what should I do to backup safely the data?
Thanks!

i had not much data to backup, so i just dumped the sql database, but there is also the data folder

BUT table structure is not the same any more, when i tried to import back my sql dump, it broke kanboard
i just finished to check every table structure and adapt the dump to the new ones manually, definitely not doable with a lot of projects/task/etc … :frowning:

I don’t know what is the best solution here
maybe here : https://kanboard.net/documentation/update

Hi, I’ve updated the kanboard package yesterday, I suggest you just update to the master branche.

To fix the admin bug on an already installed kanboard, you need to remove the plugin that cause the bug in the first place rm -rf /var/www/kanboard/plugins/*

For backup, use yunohost, there is a script for this.
yunohost backup create --ignore-hooks --apps kanboard -n kanboardonly