Xmpp-upload certificate won’t generate

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.1.6
I have access to my server : Through SSH | through the webadmin |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

xmpp-upload certificate won’t generate

Hello everyone! I have been using Yunohost for over a week now and I first want to thank you and appreciate all the hard work of everyone!

I have a problem. My yunohost server won’t regenerate xmpp-upload or muc certificates to my main yunohost domain. (which is a subdomain) I don’t have any DNS warnings other than adding A record to root domain of *. I assume this is not at all related with the problem I am having.

When I try to force regenerate certificate following error happens:
xmpp-upload.xxxx.xxxx.com' does not resolve to the same IP address as 'xxxx.xxxx.com'. Some features will not be available until you fix this and regenerate the certificate.

I have looked all other topics related to this and I have tried following:

  1. I have modified /etc/hosts file to following:
127.0.0.1       xxxx.com

127.0.0.1       xxxx.xxxx.com
127.0.0.1       xmpp-upload.xxx.xxxx.com
127.0.0.1       muc.xxxx.xxxx.com
  1. I have added my root domain CAA issuewild card. As in
xxxx.xxxx.com CAA 128 issuewild "letsencrypt.org" 

I have got these ideas from similiar topics opened here but none of it worked for me. Any ideas what might be wrong? My XMPP server works perfectly fine by the way I just can’t upload any media. Upload servers gives a certificate error when I try to connect them through browsers.

Thanks in advance. :slight_smile:

Adding to /etc/hosts doesnt matter because it’s only relevant for the local context. You should add the corresponding record to your DNS registrar (cf the result of the diagnosis which should complain about it)

Hello, thank you for the quick answer. I already have xmpp-upload part of domain pointed to CNAME to my yunohost root domain.

Or do you mean something else? I don’t have DNS warnings on my diagnosis pages other than this

And as I said in my first post I don’t think this generates the issue…

Hmmmkay but it still seem to report that

sooooo it seems to point to some issue with the DNS that should be reported in the diagnosis, specifically about xmpp-upload x_x

Or did that message disappear since then ?

Though it may also be related to the tweaking you did in /etc/hosts …

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.