Wordpress restoration failed

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 11.0.9.8
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hello,

I try to restore wordpress, but the operation fail :
https://paste.yunohost.org/raw/boputadici

The issue seems to be caused by the folder /var/www/wordpess. On the previous server, I had moved the application folder on my external storage. So I re-created the symbolic link and re-run the restoration. And now I have this issue :
https://paste.yunohost.org/raw/boputadici

Can you help me please ?

It litterly says:

2022-08-21 20:08:43,168: DEBUG - Uhoh, unknown permission wordpress.main ? (Maybe we're in the process or deleting the perm for this app...)

  1. How are you restoring your back up, CLI or GUI?
  2. it literately says:
    2022-08-21 20:08:43,168: DEBUG - Uhoh, unknown permission wordpress.main ? (Maybe we're in the process or deleting the perm for this app...)
  3. and also:
2022-08-21 20:08:48,704: WARNING - Exception: Original path for "/var/www/wordpress" not found
  1. Are you sure that the disk is mounted if it is another one and/or that your symlink is correct?

Don’t do this just edit your message!

1 Like

Hello,
I restore thé backup from the GUI.
I am sure that the external stockage is correctement mounted and the symbolic link show the good direction.
But what I am realizing is the current permission are strange :

total 228
drwxr-xr-x  5  991  988  4096 Aug 13 02:00 .
drwxr-xr-x  6 root root  4096 Mar  2  2021 ..
-rw-r--r--  1  991  988   405 Feb  6  2020 index.php
-rw-r--r--  1  991  988 19915 Jul 13 02:00 license.txt
-rw-r--r--  1  991  988  8852 Jul 13 02:00 readme.html
-rw-r--r--  1  991  988  7165 Mar 10  2021 wp-activate.php
drwxr-xr-x  9  991  988  4096 Jun 28 21:19 wp-admin
-rw-r--r--  1  991  988   351 Feb  6  2020 wp-blog-header.php
-rw-r--r--  1  991  988  2338 Feb 26 16:56 wp-comments-post.php
-rw-r--r--  1  991  988  3024 Feb 25  2021 wp-config.php
-rw-r--r--  1  991  988  3538 Feb 25  2021 wp-config-sample.php
drwxr-xr-x 12  991  988  4096 Aug 13 02:00 wp-content
-rw-r--r--  1  991  988  3943 May 28 13:22 wp-cron.php
drwxr-xr-x 26  991  988 12288 Feb 26 16:56 wp-includes
-rw-r--r--  1  991  988  2494 May 28 13:22 wp-links-opml.php
-rw-r--r--  1  991  988  3973 May 28 13:22 wp-load.php
-rw-r--r--  1  991  988 48498 May 28 13:22 wp-login.php
-rw-r--r--  1  991  988  8577 May 28 13:22 wp-mail.php
-rw-r--r--  1  991  988 23706 May 28 13:22 wp-settings.php
-rw-r--r--  1  991  988 32051 May 28 13:22 wp-signup.php
-rw-r--r--  1  991  988  4748 May 28 13:22 wp-trackback.php
-rw-r--r--  1  991  988  3236 Jun  8  2020 xmlrpc.php

What is 991 and 988 orner and group ?

In YunoHost 4.x:

chown -hR wordpress__x:wordpress__x /var/www/wordpress__x

CHANGE x to nr if you have multiple wordpress site’s otherwise just wordpress.

In YunoHost 11.x:

chown -hR wordpress__x:www-data /var/www/wordpress__x

CHANGE x to nr if you have multiple wordpress site’s otherwise just wordpress.

Thank you for your answer.
The command lines don’t work… It says me:

chown: invalid user: ‘wordpress:www-data’

you should

chown -hR wordpress__x:www-data /var/www/wordpress

How did you install WP? As app or as my web app? Have you changed anything else regarding the file permissions?

you should
chown -hR wordpress__x:www-data /var/www/wordpress

I tried it too and I get the same message

How did you install WP? As app or as my web app? Have you changed anything else regarding the file permissions?

I installed it classically from the webadmin interface. I change permission on a particular folder to access it from nextcloud.

Which change? Details, what folder did you let Nextcloud get access to, why and did it affect the wp setup?

I dont remember exactly what I did. I think I created a group with nextcloud and wordpress, and I changed the permission of the folder that contain the media of the plugin Nextgen.

I suggest restoring the permissions from your WP environment to a default state.

OK how I do that ? :sweat_smile:
What is my “WP environment” ? WP is currently not installed on the serveur.

WordPress…

Here the solution :

  1. Open the backup .tar

  2. Edit the file backup.csv and change the line

"/media/stockage/wordpress","apps/wordpress/backup/media/stockage/wordpress"

by

"/var/www/wordpress","apps/wordpress/backup/media/stockage/wordpress"

(/media/stockage/wordpress is the folder where I moved /var/www/wordpress)

  1. Recreate the .tar

  2. Run the restoration

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.