Wordpress not ready for 2.4?

,

Hi all.

I have tried to install Wordpress on a 2.4 instance but it complains that the application is not ready for this version.

Will there be an update available?

Greets
Marcus

1 Like

hello

We are working on a wordpress update to 2.4
If you want try, the update version is available at https://github.com/maniackcrudelis/wordpress_ynh

1 Like

I have tried that but it complains that there is already an instance running, even though I remove the official wordpress application before.

I have tried multiple install of WordPress without error. What kind of error have you ?

After reboot of the box I was able to install it. Within the App it complains that there is a new version of wp available. Should this be upgraded from within wp or via yunohost?

We have made the choice to let’s Wordpress make his update himself. So, the update of package does not modify the wordpress core.

I work on automatic update of wordpress. With plugins and themes. But, for the moment, it’s not ready.

Ok, thanks for the info. What I have noticed is that when I try to enable multisite, it complains that changes could not be made to the config and I should do it manually instead.

Ah, and the inline update in wp asks for login information (FTP / SFTP) in order to upgrade. Afair this was not the case with the original package. In the old version, the update simply inline worked and I cannot remember to be prompted for any credentials.

For updating, sorry it’s a mistake. WordPress doesn’t have right to write. I’ll correct that this evening !

And for multisite option, have you check if multisite is finally enable? An error message is printed, but is not a problem. I’ve notified that in french only, sorry ! I’ll try to remove the error message.

Hi again. Have you been able to push the fixes yet?

Sorry, I was thinking you follow on github.
I corrected the 2 fixes. You can update you wordpress installation with

sudo yunohost app upgrade wordpress -u https://github.com/maniackcrudelis/wordpress_ynh

It works fine now. Thanks a lot.

it seems there is a problem when installing on a fresh install. Do you have an idea ?

root@daisy:~# yunohost app install -l wordpress https://github.com/maniackcrudelis/wordpress_ynh
Choisissez un domaine pour WordPress : bidocha.pixiel.fr
Choisissez un chemin pour WordPress (default: /blog) :
Administrateur du site (doit ĂŞtre un utilisateur YunoHost existant) : lea
Choissisez la langue du WordPress [en_EN | fr_FR] (default: en_EN) : fr_FR
Activer l’option multisite ? [Yes | No] (default: No) : No
Est-ce un site public ? [Yes | No] (default: Yes) : Yes
Attention : .fonctions: ligne 20 : [: = : opérateur unaire attendu
Attention : ./remove: ligne 10: REMOVE_BDD : commande introuvable
Attention : ./remove: ligne 12: REMOVE_APP_DIR : commande introuvable
Attention : ./remove: ligne 14: REMOVE_NGINX_CONF : commande introuvable
Attention : ./remove: ligne 16: REMOVE_FPM_CONF : commande introuvable
Erreur : Échec de l’installation
root@daisy:~#

OK my mistake.

One should use this to install wordpress on 2.4
yunohost app install https://github.com/YunoHost-Apps/wordpress_ynh

thanks Maniack, installation is working => I will test further another day.

arnaud