WordPress is Down. Yunohost is OK

Bonjour à tous,

J’ai yunohost installé sur un NUC depuis quelques temps. Tout fonctionne bien. Je ne suis pas encore passé en 4.x
Subitement,ce matin, wordpress me retourne le message suivant (je n’ai fait aucune modification):

Blockquote
Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.2.0”. You are running 7.0.33-37+0~20201103.43+debian9~1.gbp25a3d7. Your Composer dependencies require the following PHP extensions to be installed: bcmath

Sûrement une MAJ automatique d’un plugin dans Wordpress… ???
Bon, je décide de faire les nombreuses MAJ en retard sur mon yunohost. Ceci se passe sans problème pour le noyau ainsi que pour toutes les appli sauf… Wordpress.

Voici le log complet : https://paste.yunohost.org/raw/azagiqicoy

Mais je pense que ca se passe par là :

Blockquote
2020-11-30 15:25:57,539: INFO - [##########++++…] > Updating plugins
2020-11-30 15:25:57,540: DEBUG -
2020-11-30 15:25:57,541: DEBUG - Your Composer dependencies require a PHP version “>= 7.2.0”. You are running 7.0.33-37+0~20201103.43+debian9~1.gbp25a3d7.
2020-11-30 15:25:57,541: DEBUG - Your Composer dependencies require the following PHP extensions to be installed: bcmath+ php7.0 /var/www/wordpress/wp-cli.phar --allow-root --path=/var/www/wordpress plugin install simple-ldap-login
2020-11-30 15:25:58,345: DEBUG - Composer detected issues in your platform:
2020-11-30 15:25:58,347: DEBUG -
2020-11-30 15:25:58,349: DEBUG - Your Composer dependencies require a PHP version “>= 7.2.0”. You are running 7.0.33-37+0~20201103.43+debian9~1.gbp25a3d7.
2020-11-30 15:25:58,350: DEBUG - Your Composer dependencies require the following PHP extensions to be installed: bcmath+ ynh_exit_properly
2020-11-30 15:25:58,352: DEBUG - + local exit_code=104
2020-11-30 15:25:58,353: DEBUG - + ‘[’ 104 -eq 0 ‘]’
2020-11-30 15:25:58,355: DEBUG - + trap ‘’ EXIT
2020-11-30 15:25:58,356: DEBUG - + set +o errexit
2020-11-30 15:25:58,357: DEBUG - + set +o nounset
2020-11-30 15:25:58,358: DEBUG - + sleep 0.5
2020-11-30 15:25:58,861: DEBUG - + type -t ynh_clean_setup
2020-11-30 15:25:58,862: WARNING - [Error] Upgrade failed.
2020-11-30 15:25:58,864: DEBUG - + ynh_clean_setup
2020-11-30 15:25:58,865: DEBUG - + ynh_restore_upgradebackup
2020-11-30 15:25:58,865: DEBUG - + ynh_print_err ‘–message=Upgrade failed.’
2020-11-30 15:25:58,869: DEBUG - + ynh_print_log ‘[Error] Upgrade failed.’
2020-11-30 15:25:58,869: DEBUG - + echo -e ‘[Error] Upgrade failed.’
2020-11-30 15:25:58,869: DEBUG - + local app_bck=wordpress
2020-11-30 15:25:58,870: DEBUG - + NO_BACKUP_UPGRADE=0
2020-11-30 15:25:58,870: DEBUG - + ‘[’ 0 -eq 0 ‘]’
2020-11-30 15:25:58,871: DEBUG - + yunohost backup list
2020-11-30 15:25:58,871: DEBUG - + grep --quiet wordpress-pre-upgrade1
2020-11-30 15:25:59,575: DEBUG - + yunohost app remove wordpress
2020-11-30 15:26:00,280: DEBUG - Suppression de l’application wordpress …
2020-11-30 15:26:01,184: DEBUG - [+…] > Loading installation settings…
2020-11-30 15:26:01,788: DEBUG - [#+++++++…] > Removing dependencies…
2020-11-30 15:26:02,893: WARNING - E: Unable to locate package wordpress-ynh-deps
2020-11-30 15:26:02,995: DEBUG - [########+…] > Removing the MySQL database…
2020-11-30 15:26:04,101: DEBUG - [#########+…] > Removing app main directory…
2020-11-30 15:26:04,503: DEBUG - [##########…] > Removing nginx web server configuration…
2020-11-30 15:26:04,705: DEBUG - [##########++…] > Removing php-fpm configuration…
2020-11-30 15:26:06,616: DEBUG - [############+++++…] > Removing fail2ban configuration…
2020-11-30 15:26:17,083: DEBUG - [#################++.] > Removing the dedicated system user…
2020-11-30 15:26:17,585: DEBUG - [####################] > Removal of wordpress completed
2020-11-30 15:26:17,688: DEBUG - wordpress supprimé

Une idée pour récupérer mon Wordpress ? Merci !!

J’ai tenté

sudo apt-get install php-bcmath

Mais le problème persiste…
Pouquoi Wordpress utilise une version antérieure à 7.0 ?

Il n’utilise pas une version antérieure à 7.0, il utilise précisément la version 7.0, mais voudrait la version au moins 7.2 … Le mieux est de faire la migration à Buster pour avoir PHP 7.3 …

1 Like

Bon du coup, j’ai pris mon courage à deux mains, croisé tous les doigts dispos…et j’ai fait la MAJ.
Tout s’est bien passé, et wordpress est reparti !
Il me reste une erreur :
Some packages were inadvertendly installed from a third-party repository called Sury. The Yunohost team improved the strategy that handle these packages, but it’s expected that some setups that installed PHP7.3 apps while still on Stretch have some remaining inconsistencies. To fix this situation, you should try running the following command: apt install --allow-downgrades libssl1.1=1.1.1d-0+deb10u3 libssl-dev=1.1.1d-0+deb10u3

Il faut le faire ce downgrade ? C’est bizarre… ??
Merci !

Oui il faut le faire … La flemme d’expliquer car c’est super technique et compliqué …

1 Like

C’est fait, je n’ai plus aucune erreur. Merci MONSIEUR Aleks !!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.