Wordpress comment changer le thème

en

#1

Bonjour,

après avoir installé wordpress sur yunohost, je me vois dans l’impossibilité de changer le thème. On ne peut, via l’interface administrateur de wordpress, choisir ou importer un thème (ce qui est possible sur mon installation wordpress chez mon hébergeur ovh).

Est-ce impossible ou faut-il télécharger le thème et l’importer à la main dans l’installation wordpress sur yunohost ?

edit : pareil pour les plugins.

Merci.


#2

Ce comportement est anormal, c’est parfaitement possible sur mon installation par exemple.

Pas eu d’erreur lors de l’installation ?

Il est possible que ce soit un problème de droits… qu’est-ce qui se passe dans tu essaye d’en installer ?


#3

Pas eu d’erreur lors de l’installation ?

non.

Il est possible que ce soit un problème de droits… qu’est-ce qui se passe dans tu essaye d’en installer ?

je n’ai même pas la possibilité de choisir un thème ou plugin à installer, il n’y a pas de boutons pour choisir un autre thème ou plugin…cf captures d’écran ci-après avec mon installation sur yunohost et mon installation chez ovh.

chez ovh, mon blog :

sur yunohost chez moi, pas de bouton pour ajouter un thème… :


#4

j’ai ça aussi dans mon panneau wordpress sur yunohost :

Installing themes on Multisite can only be done from the Network Admin section.

cela me rappelle vaguement qu’à l’installation j’ai peut-être coché une éventuelle case concernant un truc “multisite”…


#5

c’était bien cela.

J’ai désinstallé wordpress et refait l’installation sans cocher la case “multisite”

et je peux maintenant ajouter de nouveaux thèmes et plugins.


#6

Ah oui effectivement.
Si tu veux te servir de l’option multi-sites, ça se passe dans l’onglet My Sites (sur ta capture) et là tu as les réglages d’installation sur le réseau. Et ensuite ça s’active soit sur le réseau (certain plugin) donc sur tous les sites, soit par site, dans l’interface d’administration du site.


#7

d’accord, merci.


#8

un nouveau problème, j’ai installé un plugin, Simple Cache, qui m’affiche cette erreur :slight_smile:

Simple Cache can’t create or modify needed files on your system. Specifically, Simple Cache needs to write to wp-config.php and /wp-content using PHP’s fopen() function. Contact your host.

merci.


#9

L’utilisateur wordpress n’est pas autorisé à modifier 'wp-config.php’
Tu peux changer ça si tu le souhaites pour ton installation.


#10

Tu peux changer ça si tu le souhaites pour ton installation.

et comment dois-je faire cela ?

Actuellement j’ai créé un utilisateur X dans yunohost qui se log quand j’accède à l’administration wordpress. A priori il n’a pas tous les droits dans wordpress ?

merci.


#11

Pour changer le droit d’accès sur ce fichier, tu dois faire sudo chown wordpress: /var/www/wordpress/wp-config.php

L’utilisateur avec lequel tu accèdes à l’admin de wordpress dispose de tout les droits pour interagir avec wordpress.
Mais le fichier wp-config.php est interdit en écriture par le système.


#12

parfait, cela a marché. Merci de ton aide Maniack_Crudelis :-).