Wireguard on a multidomain Yunohost

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.4
I have access to my server : Through SSH | through the webadmin

Description of my issue

I have my own domain mydomain.tld, the DNS registrar is Gandi
On this domain I’ve set 3 subdomains mail.mydomain.tld, cloud.mydomain.tld, and recently vpn.mydomain.tld

I have a yunohost on a VPS, on which the main domain is mail.mydomain.tld and I have a few apps (mainly Nextcloud) associated to cloud.mydomain.tld

Before installing Wireguard, I’ve seen it only worked on its own domain, so I’ve set vpn.mydomain.tld, configured on my Gandi account, set it on Yunohost admin page, and installed Wireguard application pointing to this domain

I’ve seen that it should need a reboot, so the server has been rebooted.

Now, if I go to https://vpn.mydomain.tld/, it automatically redirects me to the classic yunohost page https://mail.mydomain.tld/yunohost/sso/ (remember that mail.mydomain.tld is the main domain on my YNH) and Wireguard is not visible as a tile once logged in as the main Wireguard user (I’ve selected myuser@cloud.mydomain.tld as the one and only one admin user for Wireguard)

Actually, i don’t know at all what I’ve missed. How can I access the Wireguard config panel to add new clients ?

Thank you !
Fred

Ooops sorry about that. The admin selected upon installation should be given the permission to access the app, which is not the case.

To fix this on your server, simply make sure the user belongs to the admins group. Meanwhile, I’ll fix the app for future installations.

1 Like

Oh right. Thank you for your answer @tituspijean !
It works perfectly :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.