Wifi Hotspot restore or install - dnsmasq error on restart

Hello everyone! I hope you are having a good day, mine has some challenges with my 8years old yunohost install (upgraded of course)

My YunoHost server

Hardware: Internet Cube with VPN
YunoHost version: 11.2.4
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: resolv conf has been changed because if I regen --force, it gives me weird conf file. So it’s modified with values from another yunohost (without hotspot). dnsmasq also had a weird behavior and I had to regen-conf --force after some past updates. dnsmasq has always caused me trouble with the hotspot and lately, before hotspot update, if I needed to restart, hotspot and dnsmasq services would be down and I would have to restart them manually.
If your request is related to an app, specify its name and version: wifi hotspot 2.1.1~ynh1 (or 2.0~ynh4 from backup)

Description of my issue

Here is what I’m trying to do webadmin or ssh :

sudo yunohost app install hotspot

but it fails with the following log : https://paste.yunohost.org/raw/enadajofel
Key point of failure is when it tries to restart dnsmasq, it says :

dnsmasq[12121]: unknown interface wlx6cfdb9aac97e

from searching the web, it says that it doesn’t like that the interface is not up (has no IP). But at that point in the install, hostapd is not up yet so the interface doesn’t have an IP so dnsmasq is not happy. It feels like a snake biting it’s tail.
On the other hand, I have a raspberry pi with a dnsmasq setup for hostapd and all is happy.
All of that to say that I feel dnsmasq config is bad and even a regen-conf --force has a bad config.

I also tried to restore my old hotspot app in version 2 (pre-upgrade backup) here are the logs: https://paste.yunohost.org/raw/luwesedohu

It’s different there where it says the

Original path for "/etc/hostapd/hostapd.conf" not found

I don’t understand what it’s trying to achieve here. I tried finding some default config files, understanding what it tries to do but I’m a little lost now
Btw, (saw that on another post), there was an adguardhome install at one point. but I’m not sure that helps.

hello, I have the same issue.

je suis sur un RPI400, Yuno 11.2.4.

the logs: https://paste.yunohost.org/raw/xowucobori

suite à la mise à jour de hotspot vers 2.1.1~ynh1.
même après une desintallation en SSH, puis une nouvelle installation, celle-ci échoue.
En webadmin, le hotspot ne parait pas dans les applications installées. Mais lorsque je vais la chercher dans le catalogue, elle parait comme installée, mais je ne peux l’activer.

image

merci d’avance pour votre aide :slight_smile:

1 Like

Hello Everyone!

Good news! I got this working :sunglasses: but not without sweat.

Some info I didn’t mention : my hardware is an Olimex A20 lime 2 and I have an external atheros wifi antenna, it’s important as I can remove it physically.

All the steps described are probably not needed but this is everything I did, sorry about that.

So from where I left off last time:

  • I detached the wifi antenna (I guess a modprobe -r my-wifi-module should do it for integrated hardware wifi)
  • I installed the wifi hotspot app: It worked! and even told me that it couldn’t start (as expected) because there’s no wifi antenna.
  • (probably not needed) did a sudo yunohost tools regen-conf dnsmasq
  • restarted the server
  • once started, as expected, the hotspot service is not up, config says there’s no antenna => good
  • I plugged the wifi antenna back.
  • I did save the config in the hotspot interface (ssid and pwd) without activating the hotspot
  • I flicked the switch to activate the hotspot and save

Bingo.

So my conclusion to this is that, it’s not ok to leave the activation of the hotspot at the same time of install. It should be kept separated. And I would suggest that the install concludes by hyperlinking directly to the hotspot setup.
I didn’t try to restore previous version hotspot though. I couldn’t get myself to get at it again.

Hope that helps.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.