Use Yunohost with my own Domain / Yunohost mit eigener Domain betreiben

Hi everybody,

i´ve been searching for instructions on using my own domain with Yunohost. There are several tutorials around for yunohost, but i couldn´t find even one that takes care about this.

I´ve never been doing this before, so please be gentle with me :slight_smile:

But at first some technical details:

Raspberry Pi 4
Latest Yunohost-Image availlable for the RasPi
FritzBox 7590
Domain hostet by STRATO

I try to keep this as simple as posible: I just want to reach my own Server on the RasPi by using my own .de - Domain. I´ve been searching various forums for clues about how to setup my FritzBox, the DNS configuration that´s necessary and at least the configuration of yunohost itself. I´ve been looking around the possible configurations given by my provider. There are several possible things to change, f.e. A-Record, AAAA-Record and even DynDNS. As the noob that i am, i have no clue about the different steps i have to make, to setup everything. But i thought “hey, it´s an server-sollution for people who have never done this before - it can´t be that difficult” :wink:
I could easily just redirect my domain to the *** page, but that´s not what i want. I just want to be a bit more independent.

I just wonder if there is any tutorial for the way that i´d like to use this. What has to be entered where?

Probably hard to explain to someone without any background, but i deny to believe, that i´m the first one with this question even though i was unable to find anything on the web.

Many thanks and best regards


Hallo allerseits,

Ich habe nach Anweisungen zur Verwendung meiner eigenen Domain mit Yunohost gesucht. Es gibt mehrere Tutorials für yunohost, aber ich konnte nicht einmal eines finden, das sich darum kümmert.

Ich habe das noch nie zuvor gemacht, also sei bitte geduldig mit mir :slight_smile:

Aber zunächst einige technische Details:

Raspberry Pi 4
Neuestes Yunohost-Image für den RasPi
FritzBox 7590
Domain Hostet von STRATO

Ich versuche es so einfach wie möglich zu halten: Ich möchte nur meinen eigenen Server auf dem RasPi erreichen, indem ich meine eigene .de - Domain benutze. Ich habe in verschiedenen Foren nach Hinweisen zum Einrichten meiner FritzBox, der erforderlichen DNS-Konfiguration und zumindest der Konfiguration von yunohost selbst gesucht. Ich habe mich nach den möglichen Konfigurationen umgesehen, die mein Provider angegeben hat. Es gibt mehrere mögliche Dinge zu ändern, z.B. A-Record, AAAA-Record und sogar DynDNS. Als totaler Anfänger, der ich bin, habe ich keine Ahnung von den verschiedenen Schritten, die ich machen muss, um alles einzurichten. Aber ich dachte “Hey, es ist eine Server-Lösung für Leute, die das noch nie gemacht haben - es kann nicht so schwierig sein” :wink:
Ich könnte meine Domain einfach auf die *** Seite umleiten, aber das ist nicht was ich will. Ich möchte nur ein bisschen unabhängiger sein.

Ich frage mich nur, ob es ein Tutorial für die Art und Weise gibt, wie ich das verwenden möchte. Was muss wo eingegeben werden?

Wahrscheinlich schwer zu erklären, ohne den nötigen fachlichen Background, aber ich kann mir auch nicht vorstellen, dass ich der erste mit dieser Frage bin, obwohl ich im Web nichts finden konnte.

Vielen Dank und schöne Grüße


I’m not sure to understand what’s blocking exactly …

If you want to add your own domain, then yes, just add the domain, either during the postinstall, or afterwards in “Domains > Add domain > I already have a domain name > … put your domain …”

Then once you’ve done this, Yunohost will provide you with the recommended DNS configuration that you need to configure on your DNS registrar (=the place where you bought your domain name)

Hi Aleks,

thanks for your answer. I wish it would have been this easy. I did just as you said, entered my own domain name, was then asked for a password, and that was it. Yunohost did al lot of work in the background, but when it finished it told me in the upper section of the screen that all was successfuly installed, and then hung up. I had to restart the server, an ´til then it was just asking me for login-data. Data that i didn´t have, wich made me create a user account via command line.

That was all that i could do after entering my own domain name. I tried it before without my domain, everything went fine, but that´s not what i want.

Is there an way to set it all back to blank? Kind of reset, wich lets me do it all again without formatting the SDCard?

Thanks a lot,


I’m not sure you need to reset anything …

Can we talk more precisely about what you did here and how exactly.

What do you mean it hang up ? Was there an error message ? Or just a blank page and the browser waiting indefinitely for an answer ? How did you access the install process in the first place : was it using the local IP ? using yunohost.local ? Or were you trying to use the domain name ?

Are we still talking about the webadmin (mostly-white page just asking for the admin password - which is the one you chose) or the user portal (mostly dark+blue page asking for a login/password, and indeed you first need to create a user to login)

If you’re redirected to the user portal by default, try to go to /yunohost/admin instead of /yunohost/sso

Sorry, i should have been more specific.

I went through the whole process in my browser. By the time it hung up, the screen was still in the “working mode”, wich means, i was not able to do something. Then the green stripe appeared and showed “installation succesfull” or something like that. The screen wasn´t changing and for 5 minutes i couldn´t do anything. Then i restarted the server. I used yunohost.local.

Everything i did was on the web interface. The only thing i did on command line was creating a new user.

I tried several times to use /yunohost/admin, but it allways jumps back to /sso.
I was typing:
It jumps to:
and the shows me the login-window. Logging in there won´t give me admin access.

Thank you so much for your time,


Uuuuh okay, which image have you been using ? 4.0 or 4.1 ?

Wow, i just found out the image i downloaded two days ago seems to be wrong. Though i´m sure i clicked the right one, it appears to be wrong. I just downloaded the “really right” image, an will try to set it all up again. Hopefully it will work, but i´ll sure let you know.

Thanks so far,


Yyyyyeah it’s because it got updated yesterday haha … but the new image should fix the whole ‘yunohost.local autoredirecting to /yunohost/sso and not /yunohost/admin’ … Though I’m also learning that the new image has some issue with mysql so i shall investigate why

So, here i am, back again from tearing out my hair. As i said, i made a new installation from the updated image. Everything went just like the first time, but without of the problems with the redirecting. :slight_smile: I still had trouble with the DNS-Setup at my provider. There was a link to some examples on how to set it up, but it was poorly helpful to me. I tried several times, made small steps in the right direction, but in the end, it all failed when i tried to open the needed Ports. Either my router or my provider are stopping my attempt to reach my server from the internet. Even though i have opened the ports on my router, but still my server is not reachable. It appears to be a problem with the IP from my Internetprovider, wich gave me a “private IP”, if you know what i mean. At least this is the only possible reason for my problem. So, finally i gave up and will try another sollution. But honestly, all this trying and reading gave me a better understanding of all this server-stuff :slight_smile:

But i still wonder why there seems to be no one else, having this problems. Probably i´m the only one with such little knowledge about servers.

Thanks for your help, i really appreciate it.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.