Upload large file to Nextcloud via SFTP

:uk: My YunoHost server

Hardware: Odroid HC2
YunoHost version: 4.2.5.3
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : Static IP in the Interfaces file + extraargs=net.ifnames=0 in /boot/armbianEnv.txt

Description of my issue

I kind of have two issues :
I want to upload large files to my Nextcloud instance, in the shared multimedia folder created with Yunohost. I can’t upload files who seems to be approximately larger than 2 Go, it gave back an Error when assembling chunks, status code 504
So, I thinked of uploading big files through the SFTP access, directly to the folder. But I can’t manage to do it, it seems the admin account doesn’t have the right to upload there (/home/yunohost.multimedia)
Either way, I’m stuck.
I would prefer uploading via SFTP, it’s easier and more reliable to me.

Thanks !

:fr: Mon serveur YunoHost

Matériel: Odroid HC2
Version de YunoHost: 4.2.5.3
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : IP Statique attribuée dans le fichier interfaces, + extraargs=net.ifnames=0 dans /boot/armbianEnv.txt

Description du problème

J’ai deux soucis :
Je souhaites uploader des gros fichiers sur mon instance Nextcloud, dans le dossier partagé Multimédia crée par Yunohost. Dès que mes fichiers dépassent à peu près les 2Go, l’upload échoue avec une Error when assembling chunks, status code 504
J’ai donc essayé d’uploader les fichiers via SFTP, en utilisant l’accès de base de l’utilisateur de base crée pour mon instance Yunohost. Je ne peux toutefois rien uploader dans le dossier /home/yunohost.multimedia.
Dans tout les cas, je suis un peu coincé. Je préférerais résoudre la question du SFTP, je trouve filezilla plus fiable dans mon cas.

Merci de votre aide !

Ton problème est un problème de droit. Tu pourrais te connecter en root, mais c’est pas simple à distance (faut faire un tunnel à travers admin).

Essai cette commande pour ajouter admin dans le groupe multimedia pour qu’il puisse écrire dans le dossier

usermod -a -G multimedia admin

Merci @ljf ! C’était bien ça !

Maintenant, la suite. Les fichiers uploadés ne s’affichent pas dans Nextcloud :neutral_face: J’ai redémarré la machine, des fois que…
J’ai trouvé un premier morceau de réponse ici en cette commande sudo -u www-data php /var/www/nextcloud-install-destination/occ files:scan --all
Est-ce qu’une autre solution spécifique à Yunohost est connue ?

Merci beaucoup !

Tu veux dire que tu as essayé cette commande ou pas ?
Pour Yunohost, il faut la modifier un peu et Ă©crire sudo -u nextcloud php7.3 /var/www/nextcloud/occ files:scan --all

Je ne suis pas assez connaisseur pour tenter ce que je ne comprends pas. Du coup, j’ai essayé ta commande et c’est bien ça, tout roule !
Je n’ai qu’une dernière question, est-ce qu’il est possible d’accéder aux paramètres FTP de Yunohost ? Pour augmenter le nom d’uploads en parallèle, ou le timeout maximum ?

Encore merci !

C’est pas une option à configurer dans filezilla ça ?

Il n’aurait pas été plus facile d’ajouter la permission sftp à l’utilisateur en question dans la gestion des groupes et permissions ?

Non car la permission sftp n’autorise logiquement l’utilisateur qu’à accéder à son propre dossier /home/USER (sauf erreurs).

Il suffit de l’uploader dans le dossier de l’utilisateur puis de se connecter au compte nextcloud de cet utilisateur et déplacer dans le dossier partagé.

1 Like

Dans le dossier de l’utilisateur du système ? Auquel cas, il faut que Nextcloud ait été installé avec l’accès à Home ?

Je viens de l’essayer chez moi. J’ai donné à un utilisateur le droit à sftp. Je me suis connecté avec filezilla, je peux accéder au dossier “/yunohost.multimedia/USER” où USER est l’utilisateur en question. J’ai pu envoyer un fichier dans ce dossier (par contre le dossier /yunohost.multimedia/share est en lecture seule). Le problème est que nextcloud ne “voit” pas le fichier. C’est une question de droit d’accès, là je ne peux pas aider, ça me depasse.
Sinon, as-tu déjà essayé l’accès webdav de nextcloud, même s’il est réputé d’être pas très performant, mais ça vaut le coup d’essayer :
https://docs.nextcloud.com/server/latest/user_manual/en/files/access_webdav.html

Sinon tu peux consulter ce lien :

https://docs.nextcloud.com/server/21/admin_manual/configuration_files/big_file_upload_configuration.html