Upgrade fails with "error processing package yunohost"

dpkg --list | grep moulinette
hi  moulinette                            3.6.4.1                                          all          prototype interfaces with ease in Python

Hmokay … Can you try to apt install moulinette --reinstall ?

Looks okay minus that last thing!


apt install moulinette --reinstall
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libtidy5 sgml-base xml-core
Use 'apt autoremove' to remove them.
The following held packages will be changed:
  moulinette
The following packages will be upgraded:
  moulinette
1 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
19 not fully installed or removed.
Need to get 0 B/67.6 kB of archives.
After this operation, 10.2 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
(Reading database ... 69938 files and directories currently installed.)
Preparing to unpack .../moulinette_3.7.0.2_all.deb ...
Unpacking moulinette (3.7.0.2) over (3.6.4.1) ...
Setting up moulinette (3.7.0.2) ...
Setting up yunohost (3.7.0.8) ...
Regenerating configuration, this might take a while...
Success! Configuration for category 'metronome' updated
Success! Configuration for category 'postfix' updated
Success! Configuration for category 'dnsmasq' updated
Success! Configuration for category 'dovecot' updated
Success! Configuration for category 'slapd' updated
Launching migrations..
Info: Running migration 0011_setup_group_permission…
Info: Creating a backup of LDAP database and apps settings prior to the actual migration.
Info: Updating LDAP schema…
Info: Updating LDAP database…
Info: Creating a group for each user…
Info: Migrating permissions from apps settings to LDAP…
Info: Migration completed. You are now able to manage usergroups.
Success! Migration 0011_setup_group_permission completed
Info: Running migration 0012_postgresql_password_to_md5_authentication…
Success! Migration 0012_postgresql_password_to_md5_authentication completed
Restarting YunoHost firewall...
Processing triggers for php7.4-cli (7.4.4-1+0~20200320.15+debian9~1.gbpf8dc20) ...
Setting up libzip4:amd64 (1.5.1-4+0~20190318173229.9+stretch~1.gbp333132) ...
Processing triggers for php7.4-fpm (7.4.4-1+0~20200320.15+debian9~1.gbpf8dc20) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for systemd (232-25+deb9u12) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up php7.0-common (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-xml (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-intl (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up libtidy5deb1 (2:5.6.0-6+0~20190131091406.8+stretch~1.gbpe69a48) ...
Setting up php7.0-mysql (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-ldap (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-readline (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-opcache (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-mbstring (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-gd (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-mcrypt (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-curl (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-zip (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-tidy (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-json (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-cli (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Setting up php7.0-fpm (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Installing new version of config file /etc/init.d/php7.0-fpm ...
Removing obsolete conffile /etc/init/php7.0-fpm.conf ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for php7.0-cli (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
Processing triggers for systemd (232-25+deb9u12) ...
Processing triggers for php7.0-fpm (7.0.33-26+0~20200320.33+debian9~1.gbp746b8e) ...
W: APT had planned for dpkg to do more than it reported back (63 vs 67).
   Affected packages: yunohost:amd64


Should I now apt update/upgrade?

If you want to, but as the logs shows (well, granted it’s probably an obscure wall of text if you don’t do this everyday) it already finished to upgrade yunohost. But just to be sure you can re-run apt dist-upgrade

(Splitted this discussion to a new topic as it’s unrelated to the original discussion about Buster)

oh—I actually do use terminals a lot—but I wasn’t sure if I should redo it just to be sure. Thanks–I appreciate it!

As it were, there ended up being a number of files that didn’t make it, so just for others:

The following packages were automatically installed and are no longer required:
  libtidy5 sgml-base xml-core
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  php7.4-curl php7.4-gd php7.4-mbstring php7.4-tidy php7.4-xml php7.4-zip
The following packages have been kept back:
  ssowat yunohost-admin
The following packages will be upgraded:
  libidn2-0 libpcrecpp0v5 libtidy5 php-apcu php-apcu-bc php-curl php-gd php-igbinary php-imagick php-mbstring php-pear php-redis
  php-tidy php-xml php-zip python3-httplib2

Final note: jumping back into admin after this and the NextCloud and Admin updates were there and ready. Did the upgrade without error.

Nice if you’re confident with the command line, could you please fix your sury pin for apt.
In /etc/apt/preferences.d/extra_php_version

You should have a pin at 200 and the second one at 600.
You should fix that before going on with your dist-upgrade !!!

Seems that I do!

Package: *
Pin: origin "packages.sury.org"
Pin-Priority: 200

Package: php7.0*
Pin: origin "packages.sury.org"
Pin-Priority: 600

Oh–that latter should be 7.4, yes?

Was it already like that when you did your dist-upgrade ?
Oh wait… you have upgraded nextcloud, so obviously it did fix it.

Could you check if you do have php7.4 now ?

I don’t:

php --version
PHP 7.0.33-26+0~20200320.33+debian9~1.gbp746b8e (cli) (built: Mar 20 2020 14:33:44) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.33-26+0~20200320.33+debian9~1.gbp746b8e, Copyright (c) 1999-2017, by Zend Technologies
php7.4 --version

Ah, yes!

php7.4 --version                                                                 PHP 7.4.4 (cli) (built: Mar 20 2020 14:24:19) ( NTS )                                                                                  Copyright (c) The PHP Group                                                                                                            Zend Engine v3.4.0, Copyright (c) Zend Technologies                                                                                        with Zend OPcache v7.4.4, Copyright (c), by Zend Technologies    

to confirm,

/etc/apt/preferences.d/extra_php_version

should say php 7.0 or 7.4?

It was probably installed just before the upgrade of Nextcloud, which should have fix the upcoming shit storm

I think now you can remove php7.4, and be careful that nothing else is removed as well.
It could prevent further failures with other apps

I had the same problems. Starting with a system-update and now trying to update Nextcloud, Bitwarden and Piwigo fails

I reinstalled moulinette, I updated yunohost, I checked the extra_php_version and the Pin Priority is as shown in the previous post (with php7.0)

Now when I try to update nextcloud it still fails - here are some logs provided by yunohost:
https://paste.yunohost.org/raw/virisividi

Any idea?
Thanks in advance

It doesn’t look that the same error at all !

Just after the backup script:

2020-03-27 21:20:43,426: WARNING - File “/usr/lib/moulinette/yunohost/backup.py”, line 708, in _collect_app_files
2020-03-27 21:20:43,429: WARNING - return self._translations[self.locale][key].encode(‘utf-8’).format(*args, **kwargs)
2020-03-27 21:20:43,430: WARNING - ValueError: Sign not allowed in string format specifier

EDIT: Apparently a mess with the translation strings, working on it.

@nr458h
A core upgrade should be available soon, it will fix the issue you had.
Update the core before trying to upgrade any apps.

1 Like

Many thanks for the quick reply!

@nr458h : fix got released, so you may upgrade (the system) again and it should be fixed

1 Like