Update/Upgrade fail

Hello everyone !

My YunoHost server

Hardware: Intel NUC at Home
YunoHost version: 4.1.7.4
**I have access to my server : Yes SSH + web
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I can’t update & upgrade my system.
When I run : sudo yunohost tools update
I face the following messages :

Info : Récupération des mises à jour disponibles pour les paquets du système…
Attention : W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/php buster InRelease: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key deb@sury.org
Attention : W: Failed to fetch https://packages.sury.org/php/dists/buster/InRelease The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key deb@sury.org
Attention : W: Some index files failed to download. They have been ignored, or old ones used instead.
Erreur : Des erreurs se sont produites lors de la mise à jour du cache APT (gestionnaire de paquets Debian). Voici un extrait des lignes du fichier sources.list qui pourrait vous aider à identifier les lignes problématiques :
sources.list:deb http://ftp.debian.org/debian buster main contrib
sources.list:deb-src http://ftp.debian.org/debian buster main contrib
sources.list:deb Index of /debian/ buster stable
sources.list:deb http://security.debian.org/debian-security buster/updates main contrib non-free
sources.list:deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
sources.list:deb http://ftp.debian.org/debian buster-updates main contrib non-free
sources.list:deb-src http://ftp.debian.org/debian buster-updates main contrib non-free
sources.list.d/extra_php_version.list:deb Index of /php/ buster main
Info : Mise à jour du catalogue d’applications…
Succès ! Le catalogue des applications a été mis à jour !
Info : Il n’y a rien à faire ! Tout est déjà à jour !
apps:
system:

How can I fix this issue ?
Thanks for your help.

Regards

Cezembre

2 Likes

Bonjour,

J’ai également une erreur sur la mise à jour :Le catalogue des applications a été mis à jour !

Mise à jour du catalogue d’applications…

Des erreurs se sont produites lors de la mise à jour du cache APT (gestionnaire de paquets Debian). Voici un extrait des lignes du fichier sources.list qui pourrait vous aider à identifier les lignes problématiques :
sources.list:deb Index of /debian buster main
sources.list:deb http://security.debian.org/ buster/updates main
sources.list.d/yunohost.list:deb Index of /debian/ buster stable
sources.list.d/extra_php_version.list:deb Index of /php/ buster main

W: Some index files failed to download. They have been ignored, or old ones used instead.

W: Failed to fetch https://packages.sury.org/php/dists/buster/InRelease The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/php buster InRelease: The following signatures were invalid: EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key

Récupération des mises à jour disponibles pour les paquets du système…

I confirm this one works :

sudo apt-key del 95BD4743; wget -nv -O - “https://packages.sury.org/php/apt.gpg” | sudo apt-key add -

Thanks !

Pour moi cela ne fonctionne pas :
admin@lesinfos:~$ sudo apt-key del 95BD4743; wget -nv -O - “https://packages.sury.org/php/apt.gpg” | sudo apt-key add -
OK
https://packages.sury.org/php/apt.gpg”: Schéma manquant.
gpg: aucune donnée OpenPGP valable n’a été trouvée.

Sounds like you have weird quotes …

just do:

sudo apt-key del 95BD4743; wget -nv -O - https://packages.sury.org/php/apt.gpg | sudo apt-key add -

J’ai exécuté la commande sans erreur mais j’ai tjours un problème pour la mise à jour Système. Je mets le log du traitement :+1: args:
apps: null
system: true
ended_at: 2021-03-27 21:54:56.061470
error: “Impossible de mettre \xE0 jour tous les paquets”
interface: cli
operation: tools_upgrade
parent: null
related_to: []
started_at: 2021-03-27 21:54:54.674811
success: false
yunohost_version: 4.1.7.3

============

2021-03-27 22:54:54,685: INFO - Mise à jour des paquets du système (non liés a YunoHost)…
2021-03-27 22:54:54,856: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::="–force-confold" -o Dpkg::Options::="–force-confmiss" -o Dpkg::Options::="–force-confdef" dist-upgrade
2021-03-27 22:54:54,973: INFO - + Lecture des listes de paquets…
2021-03-27 22:54:55,176: INFO - + Construction de l’arbre des dépendances…
2021-03-27 22:54:55,176: INFO - + Lecture des informations d’état…
2021-03-27 22:54:55,377: INFO - + Calcul de la mise à jour…
2021-03-27 22:54:55,579: INFO - + Les NOUVEAUX paquets suivants seront installés :
2021-03-27 22:54:55,580: WARNING - E: Des paquets ont été rétrogradés et -y a été employé sans --allow-downgrades.
2021-03-27 22:54:55,582: INFO - + linux-image-4.19.0-16-amd64
2021-03-27 22:54:55,582: INFO - + Les paquets suivants ont été conservés :
2021-03-27 22:54:55,583: INFO - + yunohost
2021-03-27 22:54:55,584: INFO - + Les paquets suivants seront mis à jour :
2021-03-27 22:54:55,584: INFO - + avahi-daemon base-files cloud-init debian-archive-keyring groff-base
2021-03-27 22:54:55,585: INFO - + iputils-ping libavahi-client3 libavahi-common-data libavahi-common3
2021-03-27 22:54:55,585: INFO - + libavahi-core7 libbsd0 libjs-jquery libnss-myhostname libnss-systemd
2021-03-27 22:54:55,586: INFO - + libpam-systemd libpq5 libpython3.7 libpython3.7-dev libpython3.7-minimal
2021-03-27 22:54:55,586: INFO - + libpython3.7-stdlib libssl-dev libssl1.1 libsystemd0 libudev1
2021-03-27 22:54:55,587: INFO - + linux-image-amd64 linux-libc-dev openssl postgresql-11 postgresql-client-11
2021-03-27 22:54:55,587: INFO - + python3.7 python3.7-dev python3.7-minimal python3.7-venv redis-server
2021-03-27 22:54:55,588: INFO - + redis-tools systemd systemd-sysv udev
2021-03-27 22:54:55,588: INFO - + Les paquets suivants seront mis à une VERSION INFÉRIEURE :
2021-03-27 22:54:55,589: INFO - + libssl-doc
2021-03-27 22:54:55,589: INFO - + 38 mis à jour, 1 nouvellement installés, 1 remis à une version inférieure, 0 à enlever et 1 non mis à jour.
2021-03-27 22:54:56,060: WARNING - Impossible de mettre à jour les paquets suivants : avahi-daemon, base-files, cloud-init, debian-archive-keyring, groff-base, iputils-ping, libavahi-client3, libavahi-common-data, libavahi-common3, libavahi-core7, libbsd0, libjs-jquery, libnss-myhostname, libnss-systemd, libpam-systemd, libpq5, libpython3.7-dev, libpython3.7-minimal, libpython3.7-stdlib, libpython3.7, libssl-dev, libssl1.1, libsystemd0, libudev1, linux-image-amd64, linux-libc-dev, openssl, postgresql-11, postgresql-client-11, python3.7-dev, python3.7-minimal, python3.7-venv, python3.7, redis-server, redis-tools, systemd-sysv, systemd, udev

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.