Update of Letsencrypt Certificate failed


Hi, i’m having trouble updating the (letsencrypt) certificate of my yunohost server.
I already tried debugging it on my own but i cannot find the problem.

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.1.18
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
=> I am using a specific configuration in my domain.tld.conf to be able to use my matrix server (on another instance) with the root domain:

    location ^~ '/.well-known/matrix/server' {
        return 200 "{\"m.server\":\"matrix.domain.tld:443\"}";

Description of my issue

I just want to update the Let’s encrypt certificate but every time it fails with those errors:

Verifying muc.domain.tld...
Wrote file to /tmp/acme-challenge-public/-0Mvx4JnSRY-nJb-5LlAdLveQbWM6eRTNp9lgiEAlN0, but couldn't download http://muc.domain.tld/.well-known/acme-challenge/-0Mvx4JnSRY-nJb-5LlAdLveQbWM6eRTNp9lgiEAlN0: Error:
Url: http://muc.domain.tld/.well-known/acme-challenge/-0Mvx4JnSRY-nJb-5LlAdLveQbWM6eRTNp9lgiEAlN0
Data: None
Response Code: None
Response: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1123)>
Certificate renewing for domain.tld failed!

Here the full log:

Thanks for any help!

Maybe if you’re not using XMPP, one option is to disable XMPP for that domain

I had a similar problem for the muc part of my domain and I solved or better bypassed the problem with the “–no-check” option in the command line.
See Certificate renewing attempt for domain.org failed! - #2 by lnoferin


Same issue for me, maybe because I have installed NextCloud talk and remove it,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.