Unable to update Apps

Hi everybody,

I run YNH on new-ish computer, i have access via SSH (could plug in a monitor if needed).
YNH version:
Nothing special that i’m aware of.
When i try to update ynh-apps from shell (same thing via web) i get an error:

Fehler: Du kannst das gerade nicht tun, weil dpkg/APT (der Systempaketmanager) in einem defekten Zustand zu sein scheint... Du kannst versuchen, dieses Problem zu lösen, indem du dich über SSH verbindest und `sudo apt install --fix-broken` sowie/oder `sudo dpkg --configure -a` ausführst.

It tells me that dpkg/APT are broken and that i should fix it via those two commands that i tried but to no avail.
Neither apt nor dpkg are actually broken though. I can update via apt, just not the ynh-apps.
I searched the forum and found that someone was able to fix his problems with apt through deleting Kernel 4.19.
I also deleted that Kernel. No change.
Any ideas how to proceed from here, please?

Thanks, merci, danke, mange tak

Then let’s check sudo dpkg --audit

I feel stupid now. Turns out there was something special about my system as i had the brother printer drivers installed. After removing them, system updates now.

Thanks a lot, i didn´t think of --audit.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.