Unable to install Mautrix Whatsapp and Discord Bridge

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 4.2.8.3 (stable)
I have access to my server : through the webadmin and direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance? : No, I installed the prebuilt image of the Raspberry Pi and updated everything successfully, used the dyndns nohost.me and install ssl and afterwards Synapse.

Description of my issue

I am trying to install Discord and Whatsapp Bridges for Synapse and get error message in both. Here are the logs:
Whatsapp Bridge: https://paste.yunohost.org/raw/xoluniguli
Discord Bridge: https://paste.yunohost.org/raw/iwunuguhat

Thank you!

We cannot help you if you do not respect the support topic template and if you do not provide the full log.

Hi, I have updated the post following the template. Thanks for the tip!

First error (in Whatsapp bridge) is a bug in the yunohost package : the signature key is not provided for the buster-backport repo - this works on “regular” setups which already include Debian’s key, but Raspbian uses raspberry pi repositories and therefore do not already include Debian’s key

Second issue (Discord) seems to be an issue with NPM (nodejs package manager) spontaneously breaking … somehow a link to some dependency got removed because who knows …

So can I solve this by installing YunoHost manually on a new Debian image for the raspberry pi?

Uh not sure what you mean, but this should be enough to fix the whatsapp install … maybe …

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0E98404D386FA1D9

I tried it, and it gives this error: (I tried to install whatsapp bridge again and didn’t work)

> ~ $ apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0E98404D386FA1D9
> Executing: /tmp/apt-key-gpghome.TPcMNIPBbM/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 0E98404D386FA1D9
> gpg: key 73A4F27B8DD47936: public key "Debian Archive Automatic Signing Key (11/bullseye) <ftpmaster@debian.org>" imported
> gpg: Total number processed: 1
> gpg:               imported: 1
> gpg: no writable keyring found: Not found
> gpg: error reading '[stdin]': General error
> gpg: import from '[stdin]' failed: General error
> gpg: Total number processed: 0

I meant wether i could solve the issue and get this working by fresh installing debian for the Pi and installing Yunohost afterwards from the command line.
Thanks!

Try sudo in front of the command,

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0E98404D386FA1D9

User ‘admin’ is not allowed to change (hence, ‘no writable keyring’) the apt keys, so you have to use sudo to run the command as root.