Unable to add additional domain

My YunoHost server

Hardware: Old laptop
YunoHost version:
I have access to my server : Through SSH, through the webadmin, direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I recently installed yunohost followed by the nextcloud and wallabag apps on an old laptop for use on my local network only. Everything regarding those is working great and I have no complaints there.

When I setup yunohost initially I made up a domain for use on my network “mydomain.test”, but recently I tried to create a sub-domain of it “sub.mydomain.test” and adding it failed with Could not run script: /usr/share/yunohost/hooks/conf_regen/15-nginx. I then tried to just create a different domain that wasn’t a subdomain of my current one “anotherdomain.test”, and it gave the same error for its failure (see full logs below). Any help with this would be appreciated!

Logs at https://paste.yunohost.org/raw/umadutedig

It seems to be related to a certificate issue. Have you tried to deploy a Let’s encrypt certificate on a local domain ? (it can’t work, but maybe it’s a bug if we tried that)

Have you some certificate in /etc/yunohost/certs/mydomain.test ?

ls /etc/yunohost/certs/mydomain.test

I tried to deploy a let’s encrypt certificate, but I couldn’t even start the process as the yunohost admin panel has the button disabled. So, I didn’t get anywhere with that and nothing was changed in that regards.

I do have a certificate in /etc/yunohost/certs/mydomain.test, however, I created the current one there as that’s the only way I could get the wallabag app to connect from my android phone. I kept the previous one though, so I can try switching back to the previous one and trying to add a domain again.

Edit: Regenerating the self-signed certificate solved the problem! Thanks!

1 Like

After you install a domain, you’ll need to run a diagnosis before you can install a Let’sEncrypt cert. Can you do that first and then try again to install the cert?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.