Unable to access terminal on Headless Debian Server - YunoHost restore backup?

Hello, I’m new to Yunohost and very much a beginner. My primary usage is for Nextcloud but I enjoy trying additional apps through the Yunohost App installer.

First of all thanks very much to everyone involved in the project because without you there is no chance I’d have the technical skills to have my own server:)

My YunoHost server

Old computer


I have access to my server
through the webadmin

Did you perform some particular tweaking on your YunoHost instance ?


I updated via the terminal on my headless server and now Apache server will not start but it continues to run. I no longer have access to the terminal directly on the debian server

Description of my issue

I was attempting to update some packages directly on my headless server and when it rebooted I was no longer able to access the terminal. I received an error saying Apache Server failed to launch, an now I no longer have “bash/terminal” I can’t enter commands at all.

My server is working and accessible from the web admin but I no longer have direct access on the PC. Can I simply restore a previous backup via YunoHost admin to revert my Debian install to before this mistake?

Thanks for any advice at all:)


Can you try Ctrl + Alt + F1 and F2, F3 etc ?
This combination allows you to access different terminal.
Respectively F1 = Terminal 1, F2 = Terminal 2… etc.

Yes!! That worked, Ctrl + Alt + F2 got me to the Yunohost terminal and login:)

I’m now able to access it but based on some other feedback I got, via the Matrix/IRC room, I may have some system errors. I assume every time I restart my machine I will need to use the key combination to get around it.

Is there a way to fix these system errors on Debian? My first intention, that started all this, was to install a GUI like Gnome to more easily navigate to my backups and nextcloud files.

Thanks for your help!

Great :grinning:
Do you know why Apache is installed on your server ?
Yunohost use Nginx. I think Apache won’t start because port 80 is already used by Nginx.

Can you try sudo systemctl disable apache2 and restart the server ?

Thanks, I’m not sure, I found that funny as well. I’m very ignorant to the requirements but I was at least aware of the use of Nginx … it wouldn’t be there for Wordpress would it? I have a test site running as an addon but it seems to work fine, so I guess that’s my answer.

It may have been uploaded during the manual update that I did, without understanding it:(

I’ll try that command this evening, I appreciate the tip:)

BTW is there a smart way or correct way to install Gnome desktop without breaking anything that you’d suggest? I’m quite uncomfortable using only terminal to navigate and was hoping to do manual copies/backups to an external drive by using a GUI.

I’ve restarted and no longer gettting that particular error but I think I have bigger problems… I’m getting

WARNING: Failed to connect to lvmetad. falling back to device scanning.
WARNING: Failed to connect to lvmetad. falling back to device scanning.
/dev/mapper/system-root: clean, 303927/14573568 files, 10802257/582294272 blocks

I"m able to login using Ctrl + F1 (F2, F3)

As I thought the problem does not come from Apache.
The lvmetad Warning is not important. It’s just a warning.

You can simply install a GUI with this command: apt-get install task-gnome-desktop
But before doing this, can you paste the return of this command: df -h

It’s possible that you have a disk failure. If you don’t want break your entire system, do not install a GUI before we find the real problem.

I don’t think I mentioned it here, likely on the Matrix/IRC bridge. But as I was doing the manual update it hung for quite some time and I ended up doing a hard reset…which may be the cause of some system file errors:(

No error here.

In your screenshot the command line ask you to execute sudo apt autoremove
This command clean the errors and the alone dependencies after a problem during update.

Try this command.

okay, it seems as thought it removed some failed gnome files I tried to install … libre office etc, desktop

When I reboot it still gives me the
WARNING: Failed to connect to lvmetad. falling back to device scanning. error
which I need to get around with the CTRL + F1 (F2, F3)

Is this a reasonably accurate way to use ‘fsck’ ?


unfortunately I need to leave this for tonight, I’ll check in tomorrow… thanks very much!

You can use this command any time. If your system is fine this command doesn’t change anything.

I ran the ‘fsck’ command after unmounting the system drive, I think? It gave me this response … however I’m unsure if this is the system or swap drive. I only have one drive on the system, would it typically be my /dev/sda or /dev/sdb/ ?

In your case this is sda I think.

Your can list the different partition with fdisk -l
Search for a partition with file system like ext4.

And when you execute the command, try to remove the last slash. Like this: sudo fsck /dev/sda or /dev/sda1

fdisk gave me this but I’m unsure where to see the formatting version (ext4 etc.)

when I did run ‘fsck’ on sda1 it said ‘clean’ … not sure if that means it’s okay?

It seems your disk are good.

I not shure why your system won’t boot.

As this state, the best solution are a clean install. Try to install graphical interface and make backup.
Im sorry im not able to help you more :anguished:

1 Like

Thanks for all of your help, I can’t even begin to tell you how much it’s appreciated!

Yes, I have the same thought … I’ll have to do some research on backups.

I’m just greatful that this is a non-urgent installation and it gives me the opportunity to break things and fix them. A great way to learn:)

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.