Two php versions in bullseye nextcloud gives an error

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.0.6 testing
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no /

Description of my issue

Nextcloud logs show the following error, although it says under Settings > System that it is running on PHP version 7.4.29

[PHP] Error: Composer detected issues in your platform: 
Your Composer dependencies require a PHP version ">= 7.4.0". 
You are running 7.3.33-1+0~20211119.91+debian11~1.gbp618351. 
at /var/www/nextcloud/apps/polls/vendor/composer/platform_check.php#24

Now at /etc/php I do see directories 7.3 and 7.4. Could it be that this Nextcloud Polls app somehow calls or detects version PHP7.3 and throws an error?
Also, do I need PHP7.3? Can I get rid of it?

I have many php versions installed and nextcloud runs fine on YunoHost 11.
It is not Nextcloud that choose it’s php version, it’s the web server that is configured to use a certain php executable for each site.

Which version of NextCloud do you have?

I’m just using the default yunohost install, now 22.2.3. But it seems to be the Polls app that gives this error.

Then, I think you should try 2 things :

  1. force upgrade NextCloud, staying in 22.2.3 sudo yunohost app upgrade nextcloud -F
  2. switch to the NextCloud testing branch in 23.0.3 sudo yunohost app upgrade nextcloud -u

As you are in YunoHost 11, this is the kind of problems that can occur (personally, I switched to NextCloud 23 on my YunoHost 11, and will switch back to master as soon as it is merged)

What does this first option do? Update me to the version I’m already on?
I’m not switching to testing. I very much appreciate stability of yunohost and somewhat wonder why I updated to Bullseye (answer I had the time and might not have time troubleshooting later when stable version comes out, which I expected to be around soon enough)

The 1st option will pass the upgrade scripts, but on my side, it only worked for apps that needed a change in Python version.

If it does not work, you’ll have to choose between unstability and error logs.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.