"The Domain already exists" fail in postinstall

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.1
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello everybody,

I’ve tried to install yunohost today on a fresh VPS. After setting up my VPS with a sudo user, and install via curl | bash from root (following the documentation), I proceeded to the postinstall.

Unfortunately I initally attempted to choose the same username for the sudo user and the yunohost admin. I’ve got the error message that the user ist already a system user, and therefore i got prompted back to the start of the postinstall.

So I’ve started the process again, and chose a different username for the yuno admin. But now i get the error “The Domain already exists”, which I guess is not wrong as it is the same domain as in the first try.
The easy try may be that i use a subdomain, but I would prefer not to.

Is there maybe a way to reset the postinstall process or delete the domain entry? Or is there another way to resolve this?

Install attempt from command line gives the same error.

Thank you very much in advance for your patience.

Hmmm yes indeed, that’s a bug, we should report the error early instead of crashing in the middle of the postinstall procedure and leaving the system in a half-configured state

I think you can try to reset the postinstall with the following small script. I wrote it a long time ago and did not use it (or tell people to use it) since a long time, but it should hopefully still work

(Obviously, only use it if you’re absolutely sure you want to reset the LDAP DB - just adding this obvious disclaimer in case somebody read this and yolo-run it on their server…)

curl https://raw.githubusercontent.com/alexAubin/yunoScripts/master/resetPostinstall.sh | bash

Thanks, the script still works and has succesfully reseted the pI.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.