Testing branches for apps

fr
en

#12

Hi,

Some new testings branches

baikal

#21

  • Package refactored to adjust to latest standards
  • Fix install
sudo yunohost app install https://github.com/YunoHost-Apps/baikal_ynh/tree/testing --verbose
sudo yunohost app upgrade baikal -u https://github.com/YunoHost-Apps/baikal_ynh/tree/testing --verbose

ttrss

#38

  • Package refactored to adjust to latest standards
  • Upgrade to the last current commit
  • Add opml.php to the skipped_uris string
sudo yunohost app install https://github.com/YunoHost-Apps/ttrss_ynh/tree/testing --verbose
sudo yunohost app upgrade ttrss -u https://github.com/YunoHost-Apps/ttrss_ynh/tree/testing --verbose

wordpress

#34

  • Disable http-authentication plugin which sometimes doesn’t work and break also the ldap plugin.
sudo yunohost app install https://github.com/YunoHost-Apps/wordpress_ynh/tree/testing --verbose
sudo yunohost app upgrade wordpress -u https://github.com/YunoHost-Apps/wordpress_ynh/tree/testing --verbose

zerobin

#20

  • Package refactored to adjust to latest standards
sudo yunohost app install https://github.com/YunoHost-Apps/zerobin_ynh/tree/testing --verbose
sudo yunohost app upgrade zerobin -u https://github.com/YunoHost-Apps/zerobin_ynh/tree/testing --verbose

#13

I’m trying wordpress and rainloop.


#14

Hi,

A new testing branch:

transmission

#31

  • Update of the scripts
sudo yunohost app install https://github.com/YunoHost-Apps/transmission_ynh/tree/testing --verbose
sudo yunohost app upgrade transmission -u https://github.com/YunoHost-Apps/transmission_ynh/tree/testing --verbose

#15

Hi,

A new testing branch (thanks to @jibecfed !) :

kanboard

#52

  • Global refactoring
  • Fix source URL (package was broken)
sudo yunohost app install https://github.com/YunoHost-Apps/kanboard_ynh/tree/testing --verbose
sudo yunohost app upgrade kanboard -u https://github.com/YunoHost-Apps/kanboard_ynh/tree/testing --verbose

#16

Just tested a Transmission upgrade with this testing branch: works for me :ok_hand:


#17

Hi,

There’s a new app for testing:

phpmyadmin
#63

  • Fix the error “File ./vendor/autoload.php missing or not readable.”
  • Fix composer
sudo yunohost app install https://github.com/YunoHost-Apps/phpmyadmin_ynh/tree/testing --verbose
sudo yunohost app upgrade phpmyadmin -u https://github.com/YunoHost-Apps/phpmyadmin_ynh/tree/testing --verbose

phpMyAdmin - Étapes d'installation manquanes?
#18

I have tested phpmyadmin upgrade and it works fine for me :wink:


#19

Hi,

There’s a new testing for opensondage:

opensondage
#22

  • Upgrade 1.0.3
  • Total rewriting
sudo yunohost app install https://github.com/YunoHost-Apps/opensondage_ynh/tree/testing --verbose
sudo yunohost app upgrade opensondage -u https://github.com/YunoHost-Apps/opensondage_ynh/tree/testing --verbose

#20

Upgraded rainloop to testing, so far everything works well!


#21

Upgraded wordpress to testing, no problem either


#22

Update of the testing branch of nextcloud.

#72
#64

  • Set datadir before the condition.
  • And create the directory instead of restore it, if needed.
  • Upgrade to uptream version 12.0.3
sudo yunohost app install https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --verbose
sudo yunohost app upgrade nextcloud -u https://github.com/YunoHost-Apps/nextcloud_ynh/tree/testing --verbose

#23

upgrade process worked fine (upgrade from root) and app seems to work as expected


#24

Testing branch update for Wallabag2

#41

  • Add ability to change URL
sudo yunohost app install https://github.com/YunoHost-Apps/wallabag2_ynh/tree/testing --verbose
sudo yunohost app upgrade wallabag2 -u https://github.com/YunoHost-Apps/wallabag2_ynh/tree/testing --verbose

#25

New update for the testing branches of zerobin and wordpress.

zerobin
#22

  • Update to version 1.1.1
sudo yunohost app install https://github.com/YunoHost-Apps/zerobin_ynh/tree/testing --verbose
sudo yunohost app upgrade zerobin -u https://github.com/YunoHost-Apps/zerobin_ynh/tree/testing --verbose

wordpress
#37

  • Fix ldap multisite
sudo yunohost app install https://github.com/YunoHost-Apps/wordpress_ynh/tree/testing --verbose
sudo yunohost app upgrade wordpress -u https://github.com/YunoHost-Apps/wordpress_ynh/tree/testing --verbose

#26

I try nextcloud, wallabag and wordpress.

Nextcloud and wordpress work fine.

Wallabag had an error during the backup because there was no /etc/php5/fpm/conf.d/20-wallabag2.ini.
So, I created a blank file here and I retried the upgrade. All’s ok now.
I suppose my wallabag would been quite old.


#27

Hi, new testing branche for agendav

agendav
#22

  • Fix linter and remove every sudo
  • use dependencies helpers and ynh_setup_source to clean common.sh
  • use ynh_system_user_create
  • use ynh_add_nginx_config and ynh_add_fpm_config
  • remove || true and finish users helpers
  • Multiple corrections + using helpers for back and restore
  • Update to 2.2 to be able to toggle Certificate checks on will
  • Refactoring
  • Remove skipped_uris and replace restart by reload
sudo yunohost app install https://github.com/YunoHost-Apps/agendav_ynh/tree/testing --verbose
sudo yunohost app upgrade agendav -u https://github.com/YunoHost-Apps/agendav_ynh/tree/testing --verbose

And an upgrade for transmission testing branch

transmission
#33

  • Fix permission on home/yunohost.transmission
sudo yunohost app install https://github.com/YunoHost-Apps/transmission_ynh/tree/testing --verbose
sudo yunohost app upgrade transmission -u https://github.com/YunoHost-Apps/transmission_ynh/tree/testing --verbose

#28

Hi,

Testing branch update for searx

#21

  • Fix broken package
  • upgrade scripts to latest standards
  • upgrade to upstream version 0.13.1
sudo yunohost app install https://github.com/YunoHost-Apps/searx_ynh/tree/testing --verbose
sudo yunohost app upgrade searx -u https://github.com/YunoHost-Apps/searx_ynh/tree/testing --verbose

Update Searx to 0.12.0?
#29

I try transmission and searx.
Upgrade ok.


#30

Installed SearX. Seems to be working fine, was unable to install previously.

Tried installing phpMyadmin, but it’s choking on trying to update Roundcude dependencies:

Warning: Your requirements could not be resolved to an installable set of packages.
+ ynh_die 'Unable to update Roundcube core dependencies'
+ echo 'Unable to update Roundcube core dependencies'

I have already reported being unable to update Roundcube on the stable side of things in the support forum, in French. Will check if I can upgrade to testing for Roundcube.


#31

New testing branches and new topics to announce them.
We decided to create a topic for each official apps, with more informations about each of them.

And to keep informed about each app, to announce in those topic the specific testing for each app.

So, today, there’s a testing for,