Synapse upgrade hangs -> Error 504

My YunoHost server

Hardware: CubieTruck (a.k.a. CubieBoard 3)
YunoHost version:
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes, there are a Blynk server and a MQTT server installed

Description of my issue

I have launched the Synapse application upgrade. It seems to hang and after a long time an error throws up (Error 504).

I tried also with the cli tools : yunohost app upgrade synapse
But it hangs also.

What could be wrong?

Thanks in advance for your help



Do you have any log of your upgrade ?


In general, the log file can be found in webadmin. But in this case, the webadmin always reports an error 504.
Where can I find the log file?

Well in this case it’s more nginx error. Can you try to access to your server and type this command:

systemctl status nginx

Hello Josue,

The result of the systemctl status nginx:

● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-12-05 22:00:05 CET; 14h ago
Docs: man:nginx(8)
Process: 1179 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Process: 793 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Main PID: 1241 (nginx)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/nginx.service
├─1241 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
├─1242 nginx: worker process
└─1243 nginx: worker process

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

I tried again and before I did not pay attention but it seems the system reboots after a while.

I have run the following command: yunohost app upgrade synapse
It displays the following messages:

Info: Now upgrading app synapse…
Info: […] > Loading installation settings…
Info: [+…] > Ensuring downward compatibility…
Info: [#++++++++…] > Backing up the app before upgrading (may take a while)…
Warning: 14856 [WARN] /var/lib/matrix-synapse will not be saved, because ‘BACKUP_CORE_ONLY’ is set.
Warning: 16088 could not change directory to “/home/yunohost.backup/tmp/synapse-pre-upgrade1/apps/synapse/backup”: Permission denied
Info: [#########++…] > Upgrading dependencies…
Info: [###########+…] > Upgrading source files…
Info: [############+…] > Updating synapse config…
Warning: [WARN] File /etc/matrix-synapse/homeserver.yaml has been manually modified since the installation or last upgrade. So it has been duplicated in /home/yunohost.conf/backup//etc/matrix-synapse/homeserver.yaml.backup.20191206.083541
Warning: [WARN] File /etc/matrix-synapse/log.yaml has been manually modified since the installation or last upgrade. So it has been duplicated in /home/yunohost.conf/backup//etc/matrix-synapse/log.yaml.backup.20191206.083543

It is running since 8h30 am this morning and has not completed now.

Which log file can I check?

Thanks in advance


You can see all log here : /var/log/yunohost/yunohost-cli.log

Something goes wrong and now Synapse is no longer on the system :frowning:

Probably the upgrade failed and synapse was removed on the upgrade process.

I finally reinstall Synapse but I lost everything.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.