Synapse: Sign in webside doesnt work

Today I found out that when I press login with CAS on a new matrix client, I get redirected to Yunohost SSO instead of the Synapse login page. Any help would be really appreciated

I also have this error. Unable to connect a new Element client to it.
I can no longer connect my clients (Element) on Android or on my PC


It should be done by default, and not removable, but can you check in the autorisations if Synapse (Server access for client apps.) is available for visitors ?
(And Synapse just for logged in users)

It’s Ok for the autorisations

It only offers the CAS identification but the latter points to the root of the domain and takes you back to the Yunohost home page

In fact, there is no longer a connection suggestion with password and username despite the option being activated.

Is it ok both for visitors and all_users groups ?

Here is my configuration :

In absolute terms I have a snapshot but that does not correct the problem because after the update it will come back


I dont have time to find the problem with the sso (seem a problem with the nginx configuration to allow acces to the cas_server.php page…)

But you can enable login password

Edit /etc/matrix-synapse/homeserver.yaml

search password_config and set enabled value to true

    # Uncomment to disable password login
    enabled: true

Then restart synapse

systemctl restart matrix-synapse.service

Thank you very mutch @kaulian.

I face also the same issue.
I noticed there is an issue reported on Github at Attempting to log in only shows the CAS option, resulting in a loop · Issue #412 · YunoHost-Apps/synapse_ynh · GitHub S I guess sure the Dev are informed already.

As a temporary solution, I have applied the homeserver.yaml modification suggested by @kaulian with success. Thanks to you for this quick solution!

Waiting for a more sustainable solution :slightly_smiling_face:


I succeed to fix this by changing user, group and chdir:



user = matrix-synapse
group = matrix-synapse

chdir = /var/www/synapse

listen = /var/run/php/php7.4-fpm-synapse.sock
listen.owner = www-data = www-data

pm = ondemand
pm.max_children = 16
pm.max_requests = 500
request_terminate_timeout = 1d

pm.process_idle_timeout = 10s

; Additional php.ini defines, specific to this pool of workers.

php_admin_value[upload_max_filesize] = 100M
php_admin_value[post_max_size] = 100M

And restart:

systemctl restart php7.4-fpm

I have tried both this approach and also the one described on GitHub that worked for me in the past, the one that disables three strings within the yaml file. I got to log in on two devices in 2022.

And that’s it. As of today, I am unable to sign in on a new device.

I’m not asking for help this time, just a comment. I hope Synapse for YunoHost gets better soon, I really don’t want to use WhatsApp or Telegram, and XMPP isn’t the user-friendliest option either.

(Edited) I was having trouble with this seemingly not working. It was just a typo though (I was missing the /php/ in my Nginx config). In short, the version posted above combined with changing the Nginx config (correctly!) worked for me.

The Yunohost community is the best! :two_hearts:

worket for me

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.