Synapse 1.65 update failed


I just tried to update synapse from 1.59 to 1.65 and it has failed. Synapse is completely gone and I cannot restore the pre-upgrade backup.

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version:
I have access to my server: Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance? Yes, I modified dphys-swapfile to use up to 8GB of swap.

Description of my issue

  • I was running Synapse 1.59 and saw there was an update available. I clicked on it (webadmin) and it started the process but it failed (log).
  • Synapse was completely gone — new version didn’t install and the backup wasn’t restored (log).
  • I usually remove the webapp before updating synapse to avoid conflicts, but I forgot to do it this time (matrix’s identity is my main domain name, where the main website is hosted).
  • I removed the webapp and tried to restore the backup but it didn’t work either (log).

Can you help me?


I realised that there was a new user on the server: synapse, that must’ve been created automatically when trying to upgrade to 1.65.

I removed the user and tried restoring synapse 1.59 but it failed once again.

I must say that I have two synapse instances on two subdomains (I only tried to update one of them, the other one still runs 1.59 and is fine), I don’t know if this is relevant, but I wonder if it is possible to have two users with the same name (synapse, one for each instance) or if this will be an issue.

I’m taking this issue to github.

I dared to try to upgrade my 2nd instance, but this time I made sure I removed my_webapp before the attempt, and everything went fine. 1.59 > 1.65 without issues.

This is what I keep getting when I try to restore the backup for the 1st instance:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/yunohost/", line 1453, in _restore_app
  File "/usr/lib/python3/dist-packages/yunohost/", line 419, in func_wrapper
    result = func(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/yunohost/", line 410, in permission_create
    raise YunohostValidationError("permission_already_exist", permission=permission)
yunohost.utils.error.YunohostValidationError: 'synapse.main' permission already exists
1 Like

My issue was fixed by executing

sudo yunohost tools shell -c "from yunohost.permission import permission_delete; permission_delete('synapse.main', force=True)"
sudo yunohost tools shell -c "from yunohost.permission import permission_delete; permission_delete('synapse.server_api', force=True)"
sudo yunohost tools shell -c "from yunohost.permission import permission_delete; permission_delete('synapse.server_client_infos', force=True)"

as instructed by @SiM on github. Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.