Suddenly: "Failed to resolve A for"

Hi all!

My yunohost-server is telling me that my dns-settings are wrong. I tried some things but nothing changed. I’m out of ideas. Can somebody help or point me in the right direction?


My YunoHost server

Hardware: Old laptop
YunoHost version: Server is running YunoHost (stable)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes, I made some changes to the sshd-config

Description of my issue

My Yunohost-server ran without problems for a long time. Around the end of September I started to get emails from Cron Daemon:


Cron <root@HOSTNAME> : YunoHost DynDNS update; sleep $((RANDOM%60)); ! ping -q -W5 -c1 >/dev/null 2>&1 || test -e /var/run/moulinette_yunohost.lock || yunohost dyndns update >> /dev/null


Failed to resolve A for

Sometimes also:

Failed to resolve AAAA for

The interesting thing is that everything is still working. The server is reachable from WAN and from LAN.

I also checked the dyndns-config which seemed fine.

Nevertheless I tried if updating the dyndns config would help: sudo yunohost dyndns update --force.

sudo yunohost domain config get
  ask: This domain is a / / and its DNS configuration is therefore automatically handled by YunoHost without any further configuration. (see the 'yunohost dyndns update' command)
  value: yunohost 
  ask: Default app
  value: _none
  ask: So far, enabling/disabling mail or XMPP features only impact the recommended and automatic DNS configuration, not system configurations!
  ask: Incoming emails
  value: yes
  ask: Outgoing emails
  value: yes
  ask: Instant messaging (XMPP)
  value: yes
sudo yunohost domain cert status
    CA_type: Let's Encrypt
    summary: Great!
    validity: 23

Diagnoses outcome:

I also upgraded the server to the latest Yunohost version. Then I rechecked everything and reconfigured everything but nothing changed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.