[Solved] Ttrss installation fails


Hi all,

I’m trying to install ttrss, which unfortunately fails. Is there anything I can do about it? the installation attempt is done on a freshly updated Debian VPS, hosting a freshly updated Yunohost. Other apps (eg. Nextcloud) are all in good shape

+ sudo service nginx reload
+ sudo rm -f /etc/cron.d/ttrss
+ sudo rm -f /etc/nginx/conf.d/coulais.me.d/ttrss.conf
+ sudo rm -rf /var/www/ttrss
ERROR 1008 (HY000) at line 1: Can't drop database 'ttrss'; database doesn't exist
+ mysql -u root -pyIF2VgfYDf -e 'DROP DATABASE ttrss ; DROP USER ttrss@localhost ;'
+ domain=XXXXX
++ sudo yunohost app setting ttrss domain
+ root_pwd=yIF2VgfYDf
++ sudo cat /etc/yunohost/mysql
+ db_name=ttrss
+ db_user=ttrss
+ app=ttrss
Exécution du script « /var/cache/yunohost/from_file/ttrss_ynh-6a8fb9f2778046755a6b743f8a45c81248c74b41/scripts/remove »...
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1183) [sender=3.1.1]
rsync: change_dir "/tmp/tmp.vsQcweUHIj/tt-rss.git" failed: No such file or directory (2)
+ sudo rsync -a '/tmp/tmp.vsQcweUHIj/tt-rss.git/*' /var/www/ttrss
+ unzip -q /tmp/ttrss.zip -d /tmp/tmp.vsQcweUHIj
+ wget -q -O /tmp/ttrss.zip 'https://tt-rss.org/gitlab/fox/tt-rss/repository/archive.zip?ref=17.1'
+ rm -f /tmp/ttrss.zip
+ ttrss_tarball=/tmp/ttrss.zip


A fix version was on the way (thanks to @scith!) and just got released. Could you please try again?

@JimboJoe @scith

it worked with the latest release. thanks and keep up the good work!

1 Like