[SOLVED] Tranmission upgrade failed

Hi everyone,

My YunoHost server

Hardware: computer at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : it could be
If yes, please explain: i’ve a simlink to an external drive for transmission progress/completed and the media directory

Description of my issue

Las transmission upgrade failed (Version 1.0~ynh3) and Yunohost was unable to restore the preupgrade backup.

I tried to reinstall Transmission but it failed too.

Here is a YunoPast of last time I tried to restore the backup : https://paste.yunohost.org/raw/nabiwodogu

Ideally, to avoid to reconfigure it, I would like to restore the backup and then run the ugrade

Thanks for your help

EDIT : It came from symlink I’ve made to put my multimedia share folder on an external HDD

Problem my can come from the fact that it tries to recreate Multimedia directories while there are already present ?

Hmokay I’m not sure to understand why it fails miserably so much to set the acl …

Can you elaborate on how you created the symlink / mount for the multimedia dir and torrent folders ?

Here is some details:

admin@artichaud:/home$ ls -al
drwxr-xr-x   8 root          root          4096 May 17 15:46 yunohost.app
drwxr-x---   5 admin         root          4096 Mar 27  2020 yunohost.backup
drwxr-x---   4 root          root          4096 May 26 06:55 yunohost.conf
drwxrwxr-x+  7 root          root          4096 May 28  2020 yunohost.multimedia
lrwxrwxrwx   1 root          root            32 Sep  4  2020 yunohost.transmission -> /mnt/data/yunohost.transmission/
ls -al yunohost.multimedia
total 32
drwxrwxr-x+  7 root     root 4096 May 28  2020 .
drwxr-xr-x  20 root     root 4096 Apr 12 09:16 ..


lrwxrwxrwx   1 root     root   16 May 28  2019 share -> /mnt/data/share/
-rwxrwxr-x+  1 root     root 2514 Dec 27 18:59 ynh_media_build.sh

I’ve forgotten that, but there’s also a simlink on /home/yunohost.transmission maybe it comes from that ?

Could also help:

ls -al /mnt/data/
total 32
drwxr-xr-x  5 root   root        4096 Jan  5 18:44 .
drwxr-xr-x  4 root   root        4096 Dec 27  2019 ..
drwxr-xr-x  2 root   root       16384 Dec 27  2019 lost+found
drwxrwxr-x+ 7 baobab multimedia  4096 Nov 24  2020 share
drw-r-----+ 5    131 www-data    4096 Dec 27  2019 yunohost.transmission

Well I deleted those symlink and I successfully restore my backup.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.