[solved] Synapse install failed on stretch


I tried to install Synapse on ARM board, on YNH 3.0beta. The install failed while starting the service. @Josue suggested to look at journalctl -u matrix-synapse log, which i did and was interesting tonight. Here is the log.


Thanks for the help


How did you try to install synapse

yunohost app install https://github.com/YunoHost-Apps/synapse_ynh/

and earlier (this morning)

yunohost app install https://github.com/YunoHost-Apps/synapse_ynh/testing/

Ok, really strange.

Could you try this new branch : https://github.com/YunoHost-Apps/synapse_ynh/tree/v0.30.0

I think more that it’s related to the two thing (ARM and YNH 3.0). I’ll inverstigate about that.

Aaaand after a long time, it failed… :slightly_frowning_face:
Here are the verbose logs :

Here are the result of journalctl -u matrix-synapse :

Could it be related to python versions ? I saw 3.0 in the first log and 2.7 in the second one… it is a pure random idea, but the only one I have…

No, it’s a problem about the libssl library. Actually I make the prebuilt package on debian jessie, so all dependence is compatible with debian jessie. And the problem with libssl is that on debian jessie we have only libssl1.0.0 and on debian strech we have libssl1.0.2 and libssl libssl1.1

So the solution might be to make a version for jessie and one for stretch.

should I try to install some other version of libssl, or wait for a stretch package ?
Thanks a lot for your help !

I’m working on a release which support the both version. So just wait some days.

Thanks !


I made a specific branch for that. So you could try here : https://github.com/YunoHost-Apps/synapse_ynh/tree/stretch_specific_package

The install failed, but the abort procedure seem to uninstall only partially what was installed. I tried twice, and the second time (the following logs), the system created a matrix-synapse__2 user etc.


after the install failed, i looked at journalctl -u matrix-synapse__2:


I hope this is usefull

Thanks again for your help


Sorry but could you try a new time because I updated the source which was wrong.
You could also try to lunch “yunohost app list” to see if any synapse instance is already installed. And after “yunohost app remove synapse” or synapse__2 maybe.

I tried again and it didn’t work :confused:


and journalctl -u matrix-synapse


I hope this helps…sorry to give you more work, thanks for your help !

Oh, really sorry,

I found the bug…

So could you try a new time ?

Now it works. Thanks a lot for your help
Guys, this stretch migration is really easy (and in my case only possible) because of you all benevolent developpers/maintainers

:heart: thanks :heart:

1 Like

Thanks to as you as well for taking a lot of time to test and report! It would be almost impossible to reach that level of quality for stable releases without your important contribution :heart: