Solved: Problem upgrading grav (Auto Date)

I have searched the forum for similar issues

on

This category is for issues regarding specific apps, NOT general issues with YunoHost.

on

This form is written in English but feel free to write in French if you’re more comfortable!

on

What app is this about, and its version

Grav 1.7.53~ynh1

What YunoHost version are you running

12.1.40.1 (stable)

What type of hardware are you using

VPS bought online

Describe your issue

Hello there,
I already solved this issue, but since it took me some (long) time to find it, I want to share my problem and the (my) solution. I hope it will help others to fix their installation:

Upgrading grav failed for a longer time.
I didn’t find any relevant “ERROR” lines in the logs, except

ERROR - Failed to upgrade grav: An error occurred inside the app upgrade script

A deeper dive showed a hint with DEBUG priority:

Preparing to uninstall Admin Panel [v1.10.56]
Checking destination... ok
Uninstallation failed.
The installed package auto-date depends on this package. Please remove it first.
Uninstallation failed or aborted.

So I did a:

sudo -u grav sh -c 'cd /var/www/grav && php8.5 bin/gpm uninstall auto-date -n'

and after that (an a clearcache) the update went smooth, and I’m now running version 2.0.21~ynh1.
There even is “Auto Date” available in grav’s admin plugin settings (I didn’t install it).

I’m not shure where this plugin comes from, but my yunohost an my grav installation both live longer on that machine, so maybe it’s something historical.

Christian

Share relevant logs or error messages

Not related, but I noticed with recent Grav update, that it sets itself as owner of my data folders, how it that? for example a nextcloud backup folder I set on an external drive