[Solved] Need "code review" for proposed app Selfoss RSS

Hi to every dev / NGINX expert,

We need some help to finalize the integration of Selfoss in Yunohost (Selfoss is a RSS feed reader).

In the beginning of 2022, ericgaspard created this repo:
GitHub - YunoHost-Apps/selfoss_ynh: Selfoss package for YunoHost It seems that he succeeded to make Selfoss work in a subdomain (I don’t know I can not test it).

I tried to help him by making it possible to install Selfoss in a subfolder: selfoss refuses to install · Issue #2 · YunoHost-Apps/selfoss_ynh · GitHub According to Selfoss documentation (link in this GitHub issue) it is possible to install it in a subfolder.

So here is my PR where I succeeded to install Selfoss in a subfolder: Install selfoss on a subfolder by Binnette · Pull Request #3 · YunoHost-Apps/selfoss_ynh · GitHub

But it seems that my solution is making Selfoss impossible to install in a subdomain. And we need it to be capable of both (subfolder and subdomain) to give both options to yunohost users.

What we need:

  1. a NGINX/YunoHost expert that can integrate my subfolder solution (my PR) and the subdomain solution (branch master).
  2. a YunoHost dev that have write access to merge the solution made in step 1
  3. a tester to test that the app works tldr: the app home page works and the app can retrieve a random RSS (I can test the subfolder part but not the subdomain…)
  4. a Yunohost dev to finalize the integration of Selfoss in the official App catalog.

Thank for any help given by the volunteer community.

PS: please don’t blame me if I didn’t post in the good forum section :innocent:

Hi there !

Thanks for your work and this sounds like the appropriate forum category :stuck_out_tongue_winking_eye:

As commented here, I think this is related to usage of root /var/www instead of alias __FINALPATH__/ though I always forget the exact behavior for root … Did you have any specific motivation to use root instead of alias ?

I think indeed the use of root instead of alias is what is causing problems. And having root /var/www is very unusual and would bring issues, I guess.

If you are using alias though, you might probably end up with an infamous NGINX bug, that can be fixed for path and root installations as in Flarum: flarum_ynh/nginx.conf at master · YunoHost-Apps/flarum_ynh (github.com)