[Solved] Gandi : API Key deprecated and new PAT dysfunctional

Hello,
the API key is now deprecated for Gandi and I tried the new PAT (personnal access token). I configure for the PAT all the permissions available and put the token in yunohost with the web admin.
But it doesn’t work and the output :

  • in the browser (api.gandi.net…) is : "“You must provide an API Key with ‘Authorization: Apikey {your-api-key}’ header”
  • and in the webadmin of yunohost : Échec de l’authentification sur l’API du registraire. Très probablement les informations d’identification sont incorrectes ? (Erreur : 500 Server Error: Internal Server Error

Am I doing something wrong ?

Thks a lot by advance

Hello,
YunoHost uses lexicon to handle requests to DNS providers. It looks like lexicon still uses the deprecated API key thing.
Unfortunately, you’ll have to wait until lexicon gets updated and integrated in YunoHost.
For the time being, you’ll have to update the DNS zone yourself :confused:

1 Like

@Tagada thks for your answer … I will try doing that myself :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.