[SOLVED] Authentication problems with both Funkwhale and Peertube

Hello people !

I’ve just installed Yunohost and was quite happy to see that I could install Funkwhale and Peertube.

Unfortunately, I cannot logging in to both of those. I tried all my passwords with all my different users and none of this seems to work. Of course all my users have been granted access to those apps.

Fyi my apps are installed on different domains :

  • Funkwhale on something like music.secondary.xyz
  • Peertube on something like video.secondary.xyz

/var/log/nginx/music.secondary.xyz-error.log & /var/log/nginx/video.secondary.xyz-error.log are both empty. I don’t receive any errors like “invalid token” or whatever. It just doesn’t allow me to logging in.

I use a different domain to log myself in but it doesn’t seem to affect SOGo or transmission for example so I guess it shouldn’t be the cause of the problem. Of course all my domains works -> I don’t have any kind of problem with my DNS and Lets encrypt certificates have been deployed for all those domains. Everything has been installed from the web interface.

My whole diagnosis report is here : https://paste.yunohost.org/ecekikukev

Thanks for your time :slight_smile:

Well I’ve just read the documentations of those and it seems that it’s just that LDAP hasn’t been implemented yet. For Funkwhale I had to log myself in via /api/admin and for Peertube I had to use the generated root password that was send to my admin email-address.

So I guess I should have RTFM :man_shrugging: